Skip to Content
1
Jan 15, 2014 at 05:02 AM

WWI - User Defined Text (long text)

342 Views

Hello Everyone,

I am having some trouble with my current outputs from WWI not pulling any data through when trying to use the User Defined Text when the data in the specification is long text.

Specification data:

User Defined Text WWI Code:

<11BRG032(M,ZAP_XXX_1010_009;*)>

<13BNG035(*:01GESTDHEADE(;*/TP))>

<01GESTDHEADE(;*/TP)[D:Start of UD Text]>

<13ENG035>

<11ERG032>

Result:

That portion works fine, however the following Specification scenario breaks the above WWI Code:

Result:

As you can see the first line is left out of the WWI and all I'm left with is the second line. I get the same error when there is simply one long text sort sequence. When a line by itself is not long text it displays correctly as well.

I am aware of a few other WWI possibilities such as the same Master repeating group with a Slave Group - User Defined Texts that has a defined type (CM from above). This only causes a Lehslay.txt error. From there I've also tried a Discrete Expansion of Multiple Values within that same slave group and master group which eliminates the Lehslay.txt error but does not output any data whatsoever.

I've tried to use the GESTDLTXTF standard SAP symbol, but because this is linked to the table location this will only output an X from the long text indicator flag in the ESTDF table within the specification.

How do I output User-Defined Long Text using SAP standard symbols?

Attachments

pastedImage_35.png (11.1 kB)
pastedImage_53.png (10.7 kB)