Skip to Content
avatar image
Former Member

Differente result Between hana views and web intelligence

Hi, i have the following issue, i get wrong data when execute a hana calculation view on web intelligence, this is the result on hana:

and this is the result in web intelligence:

1.jpg (27.2 kB)
2.jpg (69.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 17, 2017 at 10:37 AM

    is your universe pointing to the same Hana view (same server)?

    instead of checking in the Preview mode,refresh the report and see..

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      yes, in fact if i agree another dimension to the hana view i can see this in web intelligence, the problem is about data, its agree in different way.

      the select in webi is:

      SELECT

      NON EMPTY {[Measures].[StockDisponible],[Measures].[CantidadConsigna],[Measures].[StockEnConsigna],[Measures].[Valor_StockExistente],[Measures].[ValorStockCtrlCalidad],[Measures].[StockExistente]} ON COLUMNS,

      NON EMPTY [MVGR4].[MVGR4].[MVGR4].Members

      DIMENSION PROPERTIES PARENT_UNIQUE_NAME, [MVGR4].[MVGR4].[MVGR4].[MVGR4] ON ROWS

      FROM [ZSTOCKS_V2]

  • avatar image
    Former Member
    Jan 24, 2017 at 04:11 PM

    still have this issue, i dont know solution it can be problem of the select of the query panel

    Add comment
    10|10000 characters needed characters exceeded

    • Can you edit the webi scripts and remove the "NON EMPTY" part from the sql and run.

      i don't have idea from HANA side but it seems issue with "NON EMPTY" syntax.

      check why it's coming in the SQL.might be something you have selected in the universe object propetries.

  • avatar image
    Former Member
    Jan 25, 2017 at 10:57 AM

    im not able to edit the query, anyway i could change option to bring empty rows but still dont bring me correct data

    Add comment
    10|10000 characters needed characters exceeded