Skip to Content
avatar image
Former Member

merge cell in ALV column

hi, everyone

I have a question, hope your quick support. I try to descript it in following:

I have a ALV, and I need to merge the cells in one column, which the value in this column is same.

I think there is a field named NO_MERGING, if I don't set it as 'X', then I can achieve what I want.

But it looks not correct, NO_MERGING is null, but when I sort the column, the same value cell don't merge.

Does anyone has some suggestion? or who know the reason for my problem, wait for your response.

thanks a lot

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 24, 2005 at 07:58 PM

    Hi,

    See this sample program BCALV_TEST_MERGE. This may answer your question.

    Regards,

    Kasthuri Rangan Srinivasan.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 24, 2005 at 11:07 AM

    once the ALV grid is rendered, go to change layout->display->withou cell merging during sorts (uncheck this check box)

    Regards

    Raja

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 24, 2005 at 11:08 AM

    Hi,

    In your field catalog

    set

    NO_MERGING = ''. its two single quote.

    for those field you want to merge cells with similar values.thats it.

    or

    NO_MERGING = 'X'.

    if dont want to merge.

    reward points if it solves yor problem

    Message was edited by: Anid

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 24, 2005 at 11:19 AM

    Thank you for your reply.

    Raja, I think the layout setting in display menu is equivalent to the IS_LAYOUT.

    But my problem is, in my ALV, even the all the checkboxs in that screen have been cleared, the cell still can't be merge.

    I have no idea on it.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 24, 2005 at 11:51 AM

    Hi,

    To disable cell merging,I hope no_merging = 'X',otherwise you need to give no_merging = ''.

    While calling set_table_for_first_display,in debugging just chk your layout-no_merging property.

    If it is not reflected,just try changing in debugging and observe why that is happening.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2005 at 07:12 AM

    Actually, I find a phenomena, that if there exist some fields are editable, then the cell can't be merged.

    Only when all the fields can be edit, then the same value cell will be merged after sort on associated column.

    I don't know if I can do more than this, but this is the rule I find out.

    thanks a lot for your reply.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 14, 2011 at 11:02 AM

    Props to zhenglin gu - my Merging wasn't working until I took out my redundant "CALL METHOD r_grid->set_ready_for_input"

    Thanks! I guess the two aren't compatible, which is fine for my case, but if I find a way to make the two go together I'll post back.

    Add comment
    10|10000 characters needed characters exceeded