Skip to Content

Pinging web service not working

Hi All,

I am working on a Web service to RFC scenario. The complete scenario is as mentioned below:

Third party (Web service) -> XML Gateway (pass through) -> PI (Convert WS into RFC) -> ECC

This is a synchronous scenario. Third party here is also an SAP PI system. They are doing their configuration in SOA manager. They have created a logical port for the proxy. The connection between third party and XML Gateway is fine as I checked via telnet.

Problem is that when third party PI system tries to connect (via 'ping web service' option), we are getting the following issue:

Error      SRT Framework exception: Service Ping ERROR: Error when calling SOAP Runtime functions: SRT: Couldn't create Object: ("ICF Error when creating HTTP client object by Config for URL -----

I would like to check if connection is already set up and telnet working, might this be a network issue or some configuration being missed ?

Thanks,

Ravi.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Jan 10, 2014 at 09:40 AM

    Just to be clear, you're having issues at this point:

    Third party (Web service) -> XML Gateway (pass through)

    You are seeing the ICF error in the PI system (Third Party)?

    Can you check the ICM trace file from TX: SMICM in the PI system?

    Does the URL in the SRT error look correct?

    Are you using HTTP or HTTPs?

    Thanks,

    Darryl

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.