Skip to Content
author's profile photo Former Member
Former Member

Workitem in READY status but not in user inbox

I have a workflow in our system where the workitem is in ready status but not in user inbox.

There are three selected agents visible in workflow log but no one can see the workitem in inbox. I cant see it in SWI5 for any user as well.

The workitem was forwarded from one user to other. Now no one has the workitem in inbox.

I tried to simulate this in our test system but the receiver was able to see the workitem in his inbox.

I found same question raised in following link, but it is not answered.

SAP inbox forward to user STATUS 'READY' | SCN

As a work around i have created a new workflow which is visible for the same users, but would like to know what may have gone wrong.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2014 at 01:44 PM

    Hi,

    Please refresh buffer also SWU_OBUF transaction.

    try again by retriggering the workflow.

    Regards,

    Ragav

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Rick Bakker

      Hello Rick,

      in work item i can see text "Forwarded by" followed by the user name. Don't have any entry in SWWUSERWI. I have logically deleted the workflow so that i could trigger a new one. I think that's the reason why the workitem is no longer available in SWWUSERWI.


      I have checked KBA 1560336 which talks about note 1308276

      Scenario is same but we are on SAP_BASIS 700 - SAPKB70027 and the note is valid till Package SAPKB70018.


      Don't know what went wrong 😕


      Regards,

      Mrugesh.

      Message was edited by: Mrugesh Phatak

  • Posted on Jan 09, 2014 at 01:18 PM

    Hi,

    Just check in the task -> agentAssignment -> Atrributes. What radio button is click, if forwarding not allowed or general forwardin not allowed(user not in possible agent), then you can't forward the task.

    Check and share screensho t

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 10, 2014 at 06:44 PM

    Check if the user to whom the workitem was forwarded is a dialog user.

    The user should be of type dialog.

    User Types (SAP Library - SAP Web Application Server Security Guide)

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 11, 2014 at 05:04 AM

    Hi,

    As I have also faced same like when forwarded WI, I am able to see in Workflow log in SWIA.

    But UWL is not found at receiving Agent UWL.

    As Sahir told, I have cleared browsing history, clear cache and Changed USER TYPE to Dialog.

    That solved my issue.

    http://scn.sap.com/thread/3479401

    Thanks

    Krishna

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 13, 2014 at 02:15 PM

    Hi Mrugesh

    By any chance, is the user, to whom the WI is forwarded to, an Excluded Agent in the work item?

    Regards,

    Modak

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 13, 2014 at 07:16 PM

    Use FM SAP_WAPI_SET_WORKITEM_STATUS


    Here specify the Work Item ID and then give the Status as 'STARTED' and the user id to whom you want to assign the Workitem to. Hope it helps.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.