Skip to Content
author's profile photo Former Member
Former Member

WS20000019 is not triggered

Hi Workflow experts,

I have activated WS20000009, and also set the condition to start event.

After all, switch event trace ON in SWELS and performed to save credit request in VA01. Then I display the event trace in SWEL to view the event that has been triggered. But I only see there is 1 item shown

BUS2094 CREATED 08.01.2014 03:39:37 WS20000009 @5B@ SWW_WI_CREATE_VIA_EVENT_IBF

My question is why workflow WS20000019 is not triggered? Please advise what should I do now to investigate the problem.

Many thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2014 at 11:18 AM

    Food for thought hope you have already checked these things but then also

    1.) Please check SWU3 once whether all the settings are green ?

    2.) Check SWU2 whether RFCs are ok ?

    3.) Check your conditions , I think there is some thing in your conditions went wrong which creates some exceptions.

    4.) Last but not least check T-Code SWEQADM whether events get stuck there ?

    To test whether your workflow is correct:

    1.) Try to trigger the workflow using T-Code SWUE with proper BO , Event and order number.

    2.) Else you can execute the Workflow using T-Code SWUS. Check the outcomes.

    Cheers,

    Prakash

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2014 at 04:36 AM

    Hi,

    is it showing message "Reciever started" in SWEL ?

    Try to refresh the organizational buffer using tcode SWU_OBUF and try again.

    Regards,

    ibrahim

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Myahsam,

      I just had a look at WS20000019 workflow template and found that this workflow does not have any start event. As a result, this will not be shown in SWEL transaction code. If this workflow is started, you can see it in transaction code SWI1 (Workitem Report).

      Give the date & time period and execute the report. This should give you the workitem generated for this worklow (if generated).

      Regards,

      Raj

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2014 at 05:48 AM

    Hi,

    Maintain the agent assignment for the workflow , make it to general task and check.

    Regards,

    Jyothi

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 10:13 AM

    Hi,

    Check the Workflow event linkage in SWE2, it is activated or not. If it is activated check your workflow Start Conditions.

    Regards,

    Murali Krishna.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 01:25 PM


    Hi

    You are pasting the entry directly from SWEL:

    BUS2094 CREATED 08.01.2014 05:43:19 WS20000009 @5B@ SWW_WI_CREATE_VIA_EVENT_IBF

    THE @5B@ in your string is usually shown for the GREEN light Icon when you do a copy paste from SWEL to notepad / the comment box here on SCN.

    If it's a green light, this means that your workflow WS20000009 is found as the valid listener for the event. I am assuming that you are doubleclicking the above entry and you do not see "Work Item" button in the Detailed screen.

    First thing First - Ensure that there is a green check next to Configure RFC Destination on SWU3. Sometimes, the WF-BATCH password gets reset and it is no more able to login to tRFC destination to execute tRFC calls for workflows. If it is so in your case, perform the Auto Customizing of that node item in SWU3 (Config RFC Dest) if you have the auths. If you get errors, contact basis

    If this is fine, check in the SWEL detailed screen - Do we have the message "Receiver started correctly" at the lower part of the screen? If not, what do we have there - "System Overload, repeat Immediately by batch"?

    regards,

    Modak

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 11:28 PM

    Do you mean WS20000009 or WS20000019? Or both?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2014 at 07:46 AM

    The actual problem was, the settings were not activated. After tcode VA01, the workflow item has routed to the approver.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.