Skip to Content

Authorization Issue

We have 2 objects as relevant for 2 different plants - division and plant

We have 2 roles with 2 analysis objects.

Each object consists of below values.

1st object -> 1211,:,DIV1,:

2nd object -> 1222,:,DIV2,:

User added to both of these roles. Report also member of these roles.

Report has both these objects in filters.

However user gets No authorization error. Anything am missing?

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Jan 08, 2014 at 03:29 AM

    Hi Aditya,

    Your maintaining authorization objects in query designer level which place you put like char restriction or default values

    please let me know?

    Thanks,

    Phani.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 03:56 AM

    Hi,

    Please check the users under which roles you assigned.

    Please run the RSECADMIN -> go analysis tab-> give user name->select check box with log->

    select RSRT-> start extraction.

    please send error log details

    Thanks,

    Phani.


    pastedImage_0.png (17.0 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 09:15 AM

    Hi Aditya,

    Please try to run the with the help of RSECADMIN once and check for the authorization error log.

    Folowing is its procedure:

    1. RSECADMIN -> Analysis -> Execute as user -> put your user if in the Execute as user name section - > check the with log option -> check RSRT as the transaction and hit on execute.

    2. Select the query you need to check

    3. Execute it

    4. It may show output or may show "No Authorizations"

    5. come back to Execute as user screen and click on Display log button.

    6. Check for the log

    Please help us understand what exactly the error log says so that we can help you in details.

    The issues may be with the KFs or may be with some object is missing in the analysis auths you are using.

    Regards,

    Sourabh Deo

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.