Skip to Content
author's profile photo Former Member
Former Member

E-filing GB issue with BASIS version

Hello,

I am trying to implement E-filing GB for PI 7.4 Java system.
I have downloaded and imported the latest E-filing GB 1.0 SP25 in ESR.
The BASIS Software component present in system is BASIS 7.40.

But when I try to access communication channel template - PollGateway it is throwing the below given error.

software component version with nane SAP BASIS 7.00 not found.

I have latest BASIS component present in system. I have no idea why is it asking for an older version.
Can anyone help here?

Thanks,
Ari

1.png (66.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Jan 07, 2014 at 11:57 AM

    Hi Arindam,

    did you download the proper component &

    also check the below thread :

    http://scn.sap.com/thread/2014816

    Regards

    Gagan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 07, 2014 at 01:21 PM

    Hello Ari,

    Download and import the SAP BASIS 7.0 ESR content to avoid this error. See note 1536986 How to import PI Content into the ESR, for more details.

    Regards

    Mark

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2014 at 12:38 PM

    Hello All,

    Thanks for your replies.

    SAp BASIS 7.00 cannot be used as it has only HTTP adapter.

    We are working with a PI 7.4 JAVA only system (AEX). and we require the adapter type HTTP_AAE which is present in latest versions of SAP BASIS.

    The efiling content is not picking the SAP BASIS 7.40 content present in the system.

    we are unable to continue with the configuration of communication channel due to this issue.

    Please suggest.

    Thanks,

    Ari

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Ari - You are getting this error because the tpz file still uses the 7.0 metadata and it was searching for the same.

      You can find the same in the below document by Carlos Ocampos

      http://scn.sap.com/docs/DOC-40492

      "Why do you have this error when you try to import your Communication Channels from your old SAP PI 7.0 in your new SAP PI 7.31? Because new PI system use new version of Adapter Metadata belongs to SAP BASIS 7.31 software component, and your tpz files from your old SAP PI System still use Adapter Metadata from SAP BASIS 7.00. New PI can not translate one into another. But this can be done with a little of work from your side. When you close this pop-up (and you should close it several times), you are going to lose all information in your new Communication Channel"

      Possible options :

      Continue to ignore that error and may be after 3-4 times it'll allow you to select the adapter type from newer BASIS component.

      The workaround is to create a new channel template which way you might not get this error.

      I tried and both the solutions work for me

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.