Skip to Content
avatar image
Former Member

Sender RFC Adapter is not working

Hi Experts,

I have a Scenario like RFC from SAP ECC R/3 system to PI to SOAP Receiver.

I have configured the Sender RFC Channel and provided the SAP ECC R/3 Hostname and Gateway service details along with the Program ID which is to be registered through this channel in SAP ECC R/3.

when i am starting the RFC sender channel in RWB, getting the below mentioned error message.

when i check the SMGW transaction in SAP ECC R/3, Program JAGESH is not found to be registered.i think it should be registered there automatically.

Kindly suggest what i am missing.

CC_Config.JPG (60.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 07, 2014 at 11:03 AM

    Hi Jagesh

    Please ensure that the RFC destination in ECC side is working fine .. the adaptor will not work if the RFC destination connection test is failing ..

    Thanks

    Rishi

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 10, 2014 at 05:03 AM

    Hi Jagesh,

    I faced the same issue 1 week back.

    We did the following:

    1) Program Id registration on PI server.

    2) Implementation of SAP note#0001850230 as mentioned by Mark

    2) Basis team also did some configuraton changes as per note#1592493
    3) Made sure RFC Destination in ECC is pointing to ECC gateway host and service and not PI.

    Hence the issue was resolved.

    Regards,

    Pooja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pooja,

      my basis team has implemented the Note 1850230 - GW: "Registration of tp <program ID> not allowed" and now it seems when i activate the channel in PI, mentioned Program ID in channel gets registered in ECC gateway automatically; that means manual Program ID registration is not required in ECC Gateway through the OS command.

      Regards,

      Jagesh

  • Jan 07, 2014 at 10:33 AM

    Hi Jagesh,

    Please refer to SAP Note 1850230 - GW:"Registration of tp <> not allowed", this is the note that I followed to resolve my issue. You need to configure/re-deploy some security settings in SMGW as explained in the note.

    Regards,

    Mark

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2014 at 09:59 AM

    Hello,

    Did u check this?

    Process Integration (PI) &amp;amp; SOA Middleware: ... | SCN

    >>Program JAGESH is not found to be registered.i think it should be registered there automatically.

    Make sure u have created a RFC destination of Type T in Application system with the same program id which u have provided under RFC sender adapter i.e. JAGESH

    Thanks

    Amit Srivastava

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2014 at 10:46 AM

    Hi Jagesh,

    Ask to your basis team what is your sap gateway.

    Check Michal Krawczyk's blog Configuring the Sender RFC Adapter - step by step

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 07, 2014 at 10:52 AM

    Hi Jagesh,

    Please do this quick check.

    • Check whether the program id which you have mentioned is same  or not.
    • Do sm59 rfc destination check.
    • Check with your basis team and ask them to check the rfc again,user id,password and port details.whether all are correct or not.

    Regards,

    Abhi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 08, 2014 at 11:07 AM

        Hi Jagesh,

             Have you solved this problem?

            I am having the same problem . in my case Rfc Channel is working fine but the Rfc Dest is throwing error.

            I think the problem with reg file in Ecc.

    Regards,

    Anirban

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      my problem is not solved yet, as per the idea given by Rishi and Mark i have asked my basis team to do the required settings in reg file in ECC.

      by tomorrow i would be able to retest it and will revert with my result.

      Thanks and Regards,

      Jagesh