Skip to Content
author's profile photo Former Member
Former Member

LSMW recording for XK15

Hello LSMW gurus,

I have worked extensively on LSMW before for objects like batch classification etc.,

But I am having a problem as explained below:

I am trying to create LSMW for XK15 by using batch input recording.

In step 1 I created the recording

In step 2 I maintained the source structure.

In step 3 I maintained the source fields as follows:

ZKAPPL C(002) Application ZKSCHL C(004) Condition Type ZKOTABNR C(003) Table LIFNR C(010) Vendor ZMATNR C(018) Material ZEKORG C(004) Purchasing organization ZWERKS C(004) Plant ZESOKZ C(001) Purchasing Info record category ZKBETR C(011) Rate ZKONWA C(005) Rate Unit ZKPEIN C(005) Condition pricing unit ZKMEIN C(003) Condition unit ZDATAB C(008) Validity Start ZDATBI C(008) Validity End

In step 4 I maintained Structure Relations (which comes by default)

In the next step I faced the problem.

In step 5 I am trying to map the fields by assigning the source field but I don't see any fields to assign. When I click on the button "Create Source field" it prompts me to position the cursor on a field.

Why am I not seeing the fields (which I have seen in the case of MSC1N recording)?

Thanks in advance

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jan 07, 2014 at 02:33 AM

    Please check the fields in step "Maintain Object Attributes"

    Check the two fields name, it will be same compare with "Maintain Source Fields"

    Check above screen shot.. the red highlighted area will be same.

    Then do "Maintain Structure Relations"

    After that you can Maintain Field Mapping and Conversion Rules..


    ScreenShot.jpg (46.4 kB)
    ScreenShot.jpg (116.0 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 07, 2014 at 03:47 AM

    Hi,

    Is the "Change Field Mapping and conversion rules" screen coming as blank by default? If so, go to the first step in change mode, go to process recording screen and click on "default all" and then save.

    Now, proceed as in normal case and check whether the recorded fields are appearing in step 5.

    If its showing the source fields, try auto field mapping with "match fields with similar names" option.

    Regards,

    AKPT


    pastedImage_0.png (29.0 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.