Skip to Content
author's profile photo Former Member
Former Member

How to change/delete/Inactive a Default Supplier type

Hi Team,

I would like to know how i can change the Default Supplier type in sourcing.

the steps i followed are

1) used workbook to upload the vendor type.

2) currently scenario :

a) XYZ 1 = default

b) XYZ 2 = default

tried to make XYZ 1 as default and removed the XYZ 2 but i am getting the error as

# Failed: object 1: Default Supplier Type already exists. [DEFAULT_TYPE].

# Failed: object 2: You can not change the default flag for the Supplier.

Now here i cannot Inactive the Supplier Type XYZ 2 as " Default supplier types cannot be inactivated."

both are set to default hence if i want only XYZ 1 to be active one how will i process further.

it would be great if any one can help me out here.

Thanks

Kanchan

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 02, 2014 at 12:25 PM

    Hi,

    Please refer the below link for editing the shopping cart in sourcing.

    http://wiki.scn.sap.com/wiki/display/SRM/New+edit+functionality+within+the+Sourcing+Cockpit

    Regards,

    RBEI/Naga.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 02, 2014 at 02:05 PM

    Hi Kanchan,

    You can add a column called INACTIVE to the import template (found in the workbook) for Supplier Type and set it to TRUE for the Supplier Type that you want to inactivate. I just tested this and it works. The flag itself does not seem to be available in the UI even if you have the appropriate permissions. I think this might be a bug -- typically what you can do in an import is the same as what you can do in the UI - so, in addition to inactivating the Supplier Type that you want to make inactive by using an import file, you might want to enter a ticket to have it looked at by Development.

    For your immediate need, you should be able to do this through an import.

    I hope this helps,

    Rosemary


    Capture.PNG (41.3 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rosemary,

      Thanks for the help,

      case 1 ) I have added column called INACTIVE to the import template and made it " TRUE" but i am still getting the error as : # Failed: object 1: You can not change the default flag for the Supplier


      case 2) : i have kept the Default_Type blank , i have also tried with default supplier type TRUE/FALSE but for those i get error message as " # Failed: object 1: You can not change the default flag for the Supplier" and " # Failed: object 1: Default Supplier Type already exists. [DEFAULT_TYPE]. " keeping the INACTIVE = TRUE.


      I think i need to raise an SAP message.


      Thanks

      Kanchan

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.