Skip to Content
author's profile photo Former Member
Former Member

OM number range working internal while it is set up as external?

Hi experts,

We are having an issue in our DEV environment where number range is set up as external but while creating position it is giving internal number. Please see attachment for details.

Thanks,

Julia..

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 31, 2013 at 04:14 AM

    Hi Julia,

    If you carry out the transaction PP01 and you want to use the external number range you should key in the object ID in the field manually. If you leave it empty you let the system generate the object ID. So please choose one object id from the range 30000000-39999999.

    If you leave the object ID field empty,

    by creating the infotype 1000 the system retrives the next avaiable number from the internal range of the subgroup $$$$ in your case!

    You can check the NR status of the subgroup $$$$, it should be 20000072 now!

    Please specify the object ID, as I wrote it before and it will work! 😉

    I hope it helps!

    András


    objid.jpg (36.6 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 31, 2013 at 06:03 AM

    Hi Juliana,

    As we know the concept in OM Number range intervals,

    $$$$ = 1st two $$ indicate the plan version & the 2nd two $$ indicate the Object type.

    In your case: You are only considering

    $$S = Any plan version for Positions that was defined as External

    Here you also need to consider that $$$$ (Any plan version & any object type) is still there/ active to generate the number ranges.

    Hence If you enter the Numbers externally it will consider the $$S settings, If you do not It must consider $$$$, there might be a loop to generate numbers internally in your case.

    As suggested by Andras please check the Number Range Settings in $$$$.

    All the best,

    Srikanth Naidu. Akula

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.