Skip to Content
author's profile photo Former Member
Former Member

ICCMP_BTSHEAD edit mode set as default

Good Morning all,

I would like to set as default the edit mode of the component ICCMP_BTSHEAD.

The view have as default the buttons:

How I can set as default when you entered in WEB UI in the component, the edit mode?

I tryed to re-define the controller of the view BTSHEADER writing the following code in the method DO_PREPARE_OUTPUT without success the object is not bound.

me->view_group_context->set_view_editable( me ).

Any suggestion?

thanks

Regards

Immagine.jpg (1.5 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • Best Answer
    Posted on Dec 30, 2013 at 03:26 PM

    Hi Marco,

    Try with this code:

    DATA: lr_entity TYPE REF TO cl_crm_bol_entity,
    lr_cucobt TYPE REF TO cl_iccmp_cucobt_impl.

    lr_cucobt ?= get_custom_controller( controller_id = if_iccmp_global_controller_con=>cucobt ).

    lr_entity ?= me->typed_context->btadminh->collection_wrapper->get_current( ).
    lr_entity = lr_entity->get_root( ).

    lr_cucobt->if_iccmp_cucobt_bol_trans~edit( ir_btorder = lr_entity ).



    Best regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 30, 2013 at 03:23 PM

    if view_group_context, is initial.


    in the view controller class redefine SET_VIEW_GROUP_CONTEXT

    add following code.

    IF iv_parent_context IS INITIAL.

    CREATE OBJECT me->view_group_context TYPE cl_bsp_wd_view_group_context.

    ELSE.

    me->view_group_context = iv_parent_context.

    endif.

    then try with same code above.

    hope it will help,,

    Regards,

    Harish Kumar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 30, 2013 at 03:40 PM

    Where is the right place to write this code?

    If I write in DO_PREPARE_OUTPUT of the view controller, the application starts with edit field, but the save button and cancel button also if I press, they don't do any action.. Before the modification they runs correctly.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 30, 2013 at 03:32 PM

    Hi

    I would go for two options if the view group context is not working..

    1. Please check how you are navigating to this screen

    1.Create mode ,it opens in edit mode,no action point

    2.Display mode--- generally as per workarea component repository setttings and logicallinks.target ids..it goes to inbound plug called ip_overview...you can change the mapping to Editmode or you can write code in IP_OVERVIEW to direct it to IP_EDIT

    Option 2: In DO_INIT methods ,please get the root entity and write simple line like lr_entity->switch_to_change_mode( ). it makes view in editable mode..

    Please let me know if both are not working

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 30, 2013 at 03:31 PM

    Thank you very much, I solved with code:

    DATA: lr_entity TYPE REF TO cl_crm_bol_entity,

    lr_cucobt TYPE REF TO cl_iccmp_cucobt_impl.

    ***

    lr_cucobt ?= get_custom_controller( controller_id =

    if_iccmp_global_controller_con=>cucobt ).

    lr_entity ?=

    me->typed_context->btadminh->collection_wrapper->get_current( ).

    lr_entity = lr_entity->get_root( ).

    lr_cucobt->if_iccmp_cucobt_bol_trans~edit( ir_btorder = )

    lr_entity ).

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 30, 2013 at 03:51 PM

    At the end I used this code in DO_PREPARE_OUTPUT, in this way I'm able to save the task:

    DATA: lr_entity TYPE REF TO cl_crm_bol_entity.

    lr_entity ?=me->typed_context->btadminh->collection_wrapper->get_current( ).

    lr_entity = lr_entity->get_root( ).

    lr_entity->switch_to_change_mode( ).

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.