Skip to Content
author's profile photo Former Member
Former Member

Portal java application explicitly stopped possible root cause ?

Hi Experts,

Recently we had an issue in SAP Enterprise Portal 7.3 that the users were facing portal run time error on few sections of the portal. We checked the logs files and got the cause that a portal java application was stopped. After starting the particular portal java application the issue was resolved and users were able to access the application.

I tried to find the reason why only one portal application was stopped while rest all were working fine. Could you please give your inputs so that i can get the root cause.

FYI : One day before complete software component latest version was moved to production environment from quality environment. But this activity has been done many times in past and we never faced any application stopped issue. I am not sure why this time a single application was stopped.

Thanks & Regards

Pradeep

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 30, 2013 at 12:51 PM

    Hi,

    Please check NWA logs and see which application is stopped and why.

    Will have to provide the logs . There can me many reason if an application is not starting.

    Please post the log and the application name.

    Thanks

    Rishi Abrol

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      You can only know if you check the logs.

      The application is a cutomized java application and in logs it shows that : Global [startInitiallyApp] operation of application [*****~j2ee~ear] failed with errors on server process.

      As this is a custom application you will have to check with the developers who developed it.

      There can be many reason that the application was not started in the initial startup . May be that it has dependency on any other application and that application was not started so the startup of this application failed.

      Second thing

      One day before complete software component latest version was moved to production environment from quality environment

      As this is custom application did the developer check or fix any thing in this application after completing the software components.

      If any change that was moved for this application and system need to be rebounded to get the changes affective.

      Thanks

      Rishi Abrol

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.