Skip to Content
author's profile photo Former Member
Former Member

Backup server fails with Illegal max-length for parameter #3 for RPC as_arch_device

Hi

I've just installed a new copy of ASE 15.7 (SP100) on a CentOS 6.5 server.

ASE appears to work fine, but the backup server fails with "Illegal max-length for parameter #3 for RPC as_arch_device" when I try to run a dump database (or load database) command.

CentOS 6.x maps to the corresponding RH EL 6.x versions. I haven't checked if ASE is certified on RH EL 6.x - maybe I'm being a little ambitious in using this latest distro...

Any info/help would be appreciated (of course :-)

Thanks,

Michael

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2013 at 03:18 PM

    So - it was in fact a failed ebf application. Re-installing the backup server so that I have the same version for both ase and backupserver fixed the issue.

    Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2013 at 02:54 PM

    Hi Michael,

    ASe had problem like this with compression, but that should be fixed your release.

    1) Could you just do a simple database dump of model with out compression.

    2) Could you also just try a very simple configuration file default if possibly or maybe just increase

    the one you need to start as number of devices.

    Sorry for more question but I do not think this is related to Centos

    Thanks, Niclas

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Niclas,

      I think I've found the problem - looks like the backup server was running when I played the SP101 ebf, so I was running the 15.7 GA version of the backup server with the SP101 version of ASE.

      I'm reinstalling the ebf - will let you know how that goes.

      Thanks!

      Michael

  • Posted on Dec 27, 2013 at 03:16 PM

    This type of message can result from a mismatch between the ASE and Backserver versions. The parameter datatypes of the RPC calls used between ASE and Backupserver are hard-coded and occasionally get changed. In particular, the third parameter for as_arch_device got changed from a length of 30 to 255 somewhere between 15.5 and 15.7 ESD 4.2 (my best offhand guess being during the 15.7 upgrade).

    So please check that your ASE and Backupserver versions are the same.

    -bret

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.