Skip to Content

All cell contents not displayed when Exporting to Excel

Hie Guys,

I am having trouble displaying all the contents of a column when Exporting to Excel. Basically, the column is a long text that explains the status of a project. Name of the column - "Status Description". Now, I have already formatted the column to "Auto- fit Height" & "Wrap Text". All the contents of the cells are displayed when viewed in "HTML" & "PDF". However, when I export it to Excel, some column cells have not been accounted for "Auto-Fit Height". I've given the example below. Thanks.

In HTML & PDF:

Project ID Status Description

100 This project explains the status of

the project 100. The expected benefit

from the project is supposed to be

$1.2 M.

In Excel:


Project ID Status Description

100 This project explains the status of

the project 100. The expected benefit

from the project is supposed to be


Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2014 at 08:47 PM

    Hi, your issue is logged in SAP Note 1863037. An ADAPT for a fix was created bur refused by the dev team. Their reply is as below:

    First thing to say to customer is that : we don't guarantee the exact size of cells when exporting to Excel, the reason is that Excel has its own cell size unit (not very well documented by Microsoft) that we try to get as close as possible to.

    In PDF, we guarantee that size of cells will be the same as in Webi.

    The goal of exporting to Excel to do some extra calculation on data.

    If the goal is to have the same exact display as in Webi, we recommand the use of PDF instead.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 07, 2014 at 07:35 AM

    Hi,

    Have you tried using the 'Wrap Text' Functionality?

    Also try choosing the option "Prioritize the formatting of the documents" in Webi Preferences.

    Please follow the below steps to achieve this:

    Log into BI Launch Pad

    1. In the "Header" panel, click Preferences.

    2. Click Web Intelligence.

    3. Under "Select a priority for saving to MS Excel":

    Choose Prioritize the formatting of the documents to display the data in a format that is similar

    to working in Web Intelligence.

    4. Click Save and Close.

    Hope it will help!

    Thanks,

    Sakthi.

    Add a comment
    10|10000 characters needed characters exceeded

    • I tried "Prioritize east data processing", but it did not work. I guess it is a limitation of Excel 2007 when the cell size is too big. I will have to manually expand the cells in Excel to resolve this issue since there seems to be no other way. Anyways, thanks for the input.

  • Posted on Dec 27, 2013 at 05:59 AM

    Could you pls specify the BO and Excel versions you are using with SP and Patch level ?

    Also, is it possible to provide screenshots of format cell screen for both columns in the block ?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Jeewan G

      Jeevan,

      Check with prioritize data.. which might work for you. Basically this functionality should preserve the data into a standard spreadsheet disregarding any formatting issue at report..

      If this does not work then post a screenshot of the excel after fully expanding the cell of the excel..

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.