Skip to Content
author's profile photo Former Member
Former Member

Java is down:error has occurred during the execution of the Deploy software components step

Hello Experts

I am getting the below error while deploying the stack in PI of SP09;

Could not update components. Deployment of queue Queue_2013.12.18 at 15:18:58 completed with error Could not connect to Deploy Controller. Make sure that AS Java and Deploy Controller service are running. com.sap.engine.services.dc.api.ConnectionException: [ERROR CODE DPL.DCAPI.1144] Could not establish connection to AS Java on [xgscs:53304]. No alive connection. Check state of the server. Check if the host and port specified are correct and AS Java is up and running. javax.naming.NamingException: Exception during getInitialContext operation. Cannot establish connection to the remote server. [Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: Exception in creating new RemoteLoginContext instance.] com.sap.engine.services.security.exceptions.BaseLoginException: Exception in creating new RemoteLoginContext instance. com.sap.engine.services.rmi_p4.P4IOException: No alive connection. Check state of the server

Search with keywords;

SUM execute component-deploy-710 deploy-components com.sap.sdt.jspm.service.JspmService class com.sap.sdt.jspm.service.JspmServiceException

I have checked few SAP notes like

https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/sno/ui_entry/entry.htm?param=69765F6D6F64653D3030312669765F7361706E6F7465735F6E756D6265723D3138393134373726

and applied the solution also but it didnt helped.

your advice in this regard will be highly appreciated.

Thanks

Pooja

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2013 at 01:13 PM

    Hi,

    As you are checking the correct note which is for PI. What step did you follow the note.

    Can you please check if P4 port is running in the application as it says that the application cant establish p4 port.

    What is the OS .Unix or windows and see if the port is not used by any other service.

    Thanks

    Rishi Abrol

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.