Skip to Content

Hi Gurus

I am new to WAD , I am trying to execute a WAD Template but keep getting an error "Unauthorized" , I have full authorizations for all quires used in WAD Template , if I run all queries used in WAD templates using Bex Query designer , I do not get any "Unauthorization" error , reports are displayed OK for all queries used in Template , Can someone please help to analyse what is causing false authorization error? How to fix this issue ? any help would be greatly appreciated

Thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 25, 2013 at 10:39 AM

    Hi Istafa,

    Go to tcode RSUDO, use ur user id and start transaction, then execute your report.

    If you have proper authorization, it will open or it will show error.

    Thanks,

    Balaram


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 24, 2013 at 05:47 PM

    Can you provide a screenshot? Also are you executing from a role menu, portal, RSRT, or within the WAD tool itself? Need more information.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 25, 2013 at 10:31 AM

    Hi Khan

    Are you having suitable authorizations?

    Regards

    Ram

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 30, 2013 at 02:43 PM

    Hi All

    Thank you all for your prompt responses , actually it was Christmas break here for 5 days , i do not have remote access to systems ,sorry I could not reply earlier , I am sending screenshots now , problem is that when I open WAD application there are 3 data providers getting data from 3 BEX Queries , I can execute successfully all 3 queries that are feeding data to WAD template , but when I execute WAD template I am getting "UNAUTHORIZED" user error message , If I do not have authorization to all 3 queries or even one of queries used in WAD template then Un-authorization error makes sense but Since I have authorizations to all queries used in WAD templates then what is causing WAD Template to produce Unauthorization error? is there any security inside WAD template as well? pls respond

    Thanks all and sorry again for replying late as office was closed for 5 days for Christmas break

    Thanks

    Istafa


    Data Providers.JPG (41.7 kB)
    WAD Error.PNG (18.7 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • I don't rememeber the error code and i can't tell you for sure that I new which infoobject was blocked.

      It was strange but since i had an authorization error, and i don't have analysis authorization enabled, I checked my main role that i have in the system for the bw users. I found under authorization tree "Business Information Warehouse - RS" that i had a restriction for specific name pattern, the issue was with 0material so i assume was a restriction on 'S_RS_IOBJ'.

      Thank you

      Yiannis

  • Posted on Jan 02, 2014 at 08:46 PM

    Hi

    Thanks All for your great help and suggestions , really appreciate it , Problem has been resolved , there was a hidden query used in WAD Template which was not visible in Data Provider section of Template , this query was causing Un-Authorization error as it do not have proper authorization variables defined within query , I modified this query to include authorization variable ( i.e. Organization relevant variable) and it worked fine after that

    thanks again to all who helped

    Istafa

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.