Skip to Content

Prerequisites for SAP UI5 learning

Hi Team,

We are exploring SAP UI5 and would like to know the following details needed to start working on dev kit. I have gone through the prerequisite links asking to go for latest eclipse platform,abap team provider etc. I need more clarity on the following.

1. Can we not have the UI5 addon (evaluation package for UI development kit for HTML5 version 1.16.3) on the existing Netweaver developer studio already installed. (the version we have is 7.0.08) or do we still have to go for separate eclipse installation of juno or indigo.

2. Can you please provide more details on why Abap team provider is needed and any specific addon required in abap stack for this.

3.  Is there any other addon required in NW Java Stack apart from the evaluation kit 1.16.3 which we are adding to eclipse plotform.

4. Confirmation on NW sever versions from which it is supported.

5. Difference in dev kit feature while opting Eclipse Juno and Indigo versions.

Apart from these please also list down any imp points required for exploring more into this space.

thanks

Bharat.


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 24, 2013 at 07:50 AM

    1. Can we not have the UI5 addon (evaluation package for UI development kit for HTML5 version 1.16.3) on the existing Netweaver developer studio already installed. (the version we have is 7.0.08) or do we still have to go for separate eclipse installation of juno or indigo.

    2. Can you please provide more details on why Abap team provider is needed and any specific addon required in abap stack for this.

    3.  Is there any other addon required in NW Java Stack apart from the evaluation kit 1.16.3 which we are adding to eclipse plotform.

    4. Confirmation on NW sever versions from which it is supported.

    5. Difference in dev kit feature while opting Eclipse Juno and Indigo versions.

    Hi,

    Please see my answers.

    1. No. You need to install it on top of eclipse installation. Refer https://tools.hana.ondemand.com/#sapui5

    2. Refer SAPUI5 SDK - Demo Kit and http://scn.sap.com/docs/DOC-42820

    3. You need to have Prerequisites as mentioned in point 1

    4. Again refer SAPUI5 SDK - Demo Kit

    5. As per my opinion, there should not be any difference but as per SAP Development Tools for Eclipse use Juno version 4.2 or higher.

    Regards,

    Chandra

    Add comment
    10|10000 characters needed characters exceeded

    • Ram K Chandrashekhar Mahajan

      Hi Chandra,

      Can you let me know  the steps  to add an SAP WEBAS server in ECLIPSE JUNO. We are able to add tomcat and deploy it successfully but i am not able to add SAP servers as there is  no option of SAP in preferences. I read that we have SAP NetWeaver Server Adapter for Eclipse but this is only for older versions of eclipse.

      regards

      Bharat

  • avatar image
    Former Member
    Jan 03, 2014 at 09:13 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      While trying to installl new software from Eclipse....> Help and pasting the link https://tools.hana.ondemand.com/juno i get the following msg while installing the plugin's

      "SSL peer shut down incorrectly "

      this is appearing for almost all the plugin's chosen. Please let me know how to avoid this conflict.

      regards

      Bharat