Skip to Content
author's profile photo Former Member
Former Member

prompt username and password for "Upload Protected Area" in web appl

Hi, All,

We deployed a web application in Web AS 6.40 Java SP14. Because of business requirements we decide to skip the authentication of UME and implement our own authentication and authorization by servlet filter. There isn't any container-managed security setting in web.xml. We generated .ear file and deploy it with deploy tool.

Now the strange thing happens. Each time we open a new IE window and give user name and password in login page (kept in our own DB), system pops up a dialog: Enter username and password for "Upload Protected Area"... We have to input the username and password exactly the same as those we use in Connect step to deploy the application in deploy tool then everything is fine. We notice that in Security Provider of Visual Administrator there is a security role '$SAP_J2EE_Engine_Upload'. If we remove it from web component in Security Provider, the dialog still appears but we have no way to login.

Could anyone give a hint why this happens and what is the workaround?

Many thanks in advance

John

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 20, 2005 at 08:12 AM

    Hello John,

    It seems that the application is performing PUT request and is affected by the default PUT method implementation of the J2EE Engine. You can read more about it at http://help.sap.com/saphelp_nw04/helpdata/en/ee/987c69583a86468454af894f588347/frameset.htm.

    I hope this article will help you to resolve the problem.

    Kind Regards

    Vyara

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 20, 2005 at 01:35 PM

    Hi, Vyara,

    Thank you very much. After disable the default PUT implementation in Visual Administrator as you advise, the "Upload Protected Area" dialog never pops up when attempting login. Our web application works perfectly well.

    Thanks again

    John

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.