Skip to Content
0
Former Member
Dec 20, 2013 at 06:43 PM

Error Activating InfoObjects

1289 Views

Hi,

I've transported all infoobjects from our old BW system to a newly installed box. (This due to redesign, and platform switch). The problem now is that around 146 infoobjects are generating errors with activating. This is due to interdependencies (compound, attributes). So in RSD1 when (mass)activating the system asks if i want to activate the dependent objects also. When i do this eventually i get errors like "no active nametab exist for /bio/tcalmonth2". Of course it's not actively there, the log only show thease messages:

  • Message no. R7493 InfoObject 0CALMONTH2 is available in the active version, but has been deactivated.
  • Message no. R7400 Database table /BI0/TCALMONTH2 was deleted.

If I run the report RSDG_IOBJ_ACTIVATE, the log only show the same messages.

Following are the errors displayed, as per the sequence, after using RSDG_IOBJ_ACTIVATE :

  • Message no. R7159 Error/warning in dict. activator, detailed log --> Detail
  • Message no. GT236 The SQL statement was not executed
  • Message no. DT007 Table /BI0/TCALMONTH2 (Error adjusting the database)
  • Message no. AD222 INCLUDE table /BI0/TCALMONTH2 is not active
  • Message no. DT003 Routine EXPAND (Table /BI0/OTCALMONTH2 could not be expanded)
  • Message no. DO845 Row type /BI0/TCALMONTH2 is not active or does not exist
  • Message no. DO519Table /BI0/OTCALMONTH2 could not be activated
  • Message no. DO519Table /BI0/TCALMONTH2 could not be activated
  • Message no. DO519Table Type /BI0/WTCALMONTH2 could not be activated
  • Return code..............: 8
  • DDIC Object TABL /BI0/OTCALMONTH2 has not been activated
  • Error when activating InfoObject 0CALMONTH2
  • Characteristic 0CALMONTH2: Error when generating master data routines
  • Error when resetting InfoObject 0CALMONTH2 to the active version

Also if i try to import another infoobject directly in the new server by the tool BI CONTENT, but is impossible activate the infoobject, end with the same errors.

I did another test, i tried to create an Z infocube, but also ends with the same errors.

I think is an error in relation with DDIC user vs ABAP dictionary, may be DB level, i don't know if is about grants for the DDIC user o r not.

Any idea to resolve it ?

Ramon Sanchez