Skip to Content
avatar image
Former Member

7.3 Portal Theme not showing in 7.3 BEx Query iView

Hi,

like many others on SCN I am facing issues with getting a custom portal theme to work for BW reports.I have read many posts but none of them describes any solution to the issue:

http://scn.sap.com/thread/1790314
http://scn.sap.com/thread/146393
http://scn.sap.com/thread/3180234
http://scn.sap.com/docs/DOC-35785

I have also read the "Using Portal Themes in SAP NetWeaver BW" instructions on help.sap.com:
http://help.sap.com/saphelp_nw73/helpdata/en/45/ef66f1b37f3482e10000000a1553f6/content.htm

I have applied proper Desktop & Display Rules settings, e.g. alias, desktop with custom theme as default, rule collection.

Here is a system landscape and solution overview:

Enterprise Portal 7.3:

  • Federated Portal
  • BEx Query iView
  • Custom theme
  • Alias
  • Custom desktop with custom theme as default
  • Custom rule collection

BW Portal 7.3:

  • BEx report
  • No custom theme
  • No custom rule collection

When opening the BEx Query iView in Preview mode it picks up the portal theme (Tradeshow Plus). Here is a snippet from the source code:

<html><head><link rel="stylesheet" href="/com.sap.portal.design.portaldesigndata/themes/portal/

sap_tradeshow_plus/prtl_std/prtl_std_ie6.css?v=7.30.5.0.0" />
<link rel="stylesheet" href="/com.sap.portal.design.portaldesigndata/themes/portal/

sap_tradeshow_plus/glbl/glbl_ie6.css?v=7.30.5.0.0" />

When running the iView via my alias, http://<server>:<port>/irj/portal/myalias, it is showing the standard portal theme:

<html ><head ><LINK REL="SHORTCUT ICON" HREF="/web.scripting/resources/ico/favicon.ico"><link rel="stylesheet" type="text/css" href="/com.sap.portal.design.urdesigndata/themes/portal/sap_standard/

ur/ur_ie6.css?version=ce3%2BvZTH6rmQXVoe7DYwSw%3D%3D">


I have cleared the cache numerous times and closed down all IE9.0 windows. Caching should therefore not be the problem.

I have also tried to add the &STYLE_SHEET application parameter with a direct link to the custom portal theme, but without any success.

How can I solve this issue. Do I need to create custom theme in my BW portal as well, is that the problem?

Any help is highly appreciated, but please do not reply with any of the answers provided in links above as they do not work.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Dec 20, 2013 at 12:53 PM

    Hi all,

    the simple answer I have found so far is that the theme must be available in both systems in order to work.

    /Björn-Henrik

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Alan Cecchini

      Thanks Alan, that helps.

      Now I just need to figure out why I get no theme/style sheet at all for BEx when I use a LESS theme.

      Thanks again,

      Wayne