Skip to Content
avatar image
Former Member

How to install SAP Mobile platform SDK for creating iOS Mobile Application?:

I just take up the remote sever(on windows) for installing Sybase Unwired Platform 2.2 server and mobile SDK.

I could install Sybase Unwired Platform 2.2(server) successfully, But the problem is I found SAP MOBILE SDK installation at this page http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/webcontent/uuid/f00164c9-bcb7-2f10-d2b3-ac79a6faf833

but while I try installing it says: SAP mobile platform SDK 3.0 is not installed on the system and couldnt upgrade to 3.0 SP01(Please find the attached image).

I couldnt find any other installation package available in SCN, please advise.

Yoges

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 17, 2013 at 02:25 PM

    Hi Karthick,

    there is no point of installing mobile SDK 3.0 since you have only SUP 2.2 server installed.

    either you get SUP Mobile SDK 2.2 OR (you can download it from sap service market place, you must be having s-user id for downloading it otherwise you contact your company's basic administrator)

    SAP mobile plaform 3.0 server

    as far as i know you need 64 bit machine for 3.0

    Till last week, Sybase mobile sdk 2.0 and 2.4 were there at the link but seems they have replaced it with SMP SDK 3.0

    Rgrds,

    Jitendra

    Add comment
    10|10000 characters needed characters exceeded

    • The 2.2 SDK is not available in SCn right now, before it was available here. But now it is replaced with 3.0 SDK. You can download the SDK 2.2 from your SAP market place, where you downloaded the SUP server

      - Midhun VP

  • Dec 18, 2013 at 07:04 AM

    What type of mobile application you are planning to develop ? MBO based mobile apps are not supported in SMP 3.0. As Jitendra mentioned SMP 3.0 sdk will not run on SUP 2.2, you can download SUP 2.2 sdk from SAP Market place. If you are planning to develop an Odata based (SAP recommended approach) IOS applicaiton there is no need of SDK too.

    - Midhun VP

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Midhun VP

      Thanks All,& Thanks Midhun for help,

      Anyhow i tried many different ways from the Sybase forum guide could not get some of the required tools/frameworks even though they given proper implementation guide.