Skip to Content
avatar image
Former Member

Issue with archiving MM_MATBEL

Hello everyone,

We are in the process of archiving MM_MATBEL. We have made all the initial settings for the Archival process, but when we run the archive session, the job finishes and says, ' no data available'. We can able to see the data in transaction code MB51.

For the Write job variant, we have mentioned only the posting period.

Is there anything else to be performed before archiving MM_MATBEL?

Kindly clarify,




Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Dec 17, 2013 at 08:06 AM

    I have checked the MM_MATBEL..

    My archiving is okay.

    Just I have noticed that.

    Suppose I have done a GR for 100 pcs for material A in plant ZZ and sloc XX

    If the material stock is exist for 100 pcs, it will not archived..

    Can you check the job log

    Add comment
    10|10000 characters needed characters exceeded

    • this last answer was probably to quick. I just did another test and entered "FAKE" as material document number in the selection screen. And in turn SAP did not create any spool file and I have the same error in the job log like you.

      And the same situation (no spool) happens if I add a current material document number which is inside the defined residence time

      Please tell what settings you have for residence time

  • Dec 17, 2013 at 11:45 AM


    Can you tell me what's the retention period of your article document that you are trying to archive?


    Add comment
    10|10000 characters needed characters exceeded

  • Dec 17, 2013 at 08:23 PM

    Did you maintain the config table for this archiving object?

    This allows you to set document life by plant/transaction type.

    Please review tcode OMB9.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      @manjunath : No i have performed archiving for other objects and seems no problem with this user id

      @Siew: The retention period for the Material documents is 2 years (i.e.need to keep last 2 years of data in the system)

      @Michael : Yes i did maintain the config table. In OMB9, doc life for all in 200.

      @Jurgen : For Doc life, maintained Tx types WA,WE,WH,WI,WL,WO,WQ,WR,WZ for all plants.




  • Dec 18, 2013 at 03:46 AM

    My next step would be to run the archive program with a small sample set of data and set a breakpoint at the SELECT statement from MKPF and evaluate the dynamic WHERE clause that was built.

    There are also 2 BADIs that are used in the program:

    ARC_MM_MATBEL_CHECK - This BADI allows you to program custom archiability

    Check if this was previously implemented and if anything was coded there.

    There is another BADI used ARC_MM_MATBEL_WRITE which allows custom information to be written to the archive file.  I do not think that any code that may exist here will be causing documents to NOT be archived.

    Hope this helps.

    Mike Arnold

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      please check number of entries in the table MKPF for the archiving period and if you dont find any records then all got archived or if you have some records than see the material doc year for the records some time it would be in the difference between fiscal year and calender year.