Skip to Content
author's profile photo Former Member
Former Member

Multiprovider Not working Correct

I have created Multiprovider over four ODS objects. These ODS objects have 0DOC_NUM and 0DOC_Item as common infoobjects. They are having common PO numbers which i have checked in manage of each individual ODS. But when I execute the query it is showing data from only one ODS. I have maintained the proper identification of characteristics in identificatoin tab of Multiprovider design.

Guys anythoughts.

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 04:31 PM

    Hi Baljit,

    u can do 1 more thing.

    u can use infoprovider characteristic in the filter and restrict with all the ODS's .

    This shd solve ur problem

    Regards

    Majeed

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:14 AM

    Hi,

    Make sure that there the reporting property is set for all ODS.

    With rgds,

    Anil Kumar Sharma .P

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:19 AM

    Hi,

    Check if data is completely actiavted in all the ODS.

    Rohini

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:21 AM

    Hi,

    Check the query using RSRT..

    Dividing a MultiProvider Query into Sub-Queries

    http://help.sap.com/saphelp_bw31/helpdata/en/0f/17b63d799f6b3be10000000a114084/content.htm

    Executing Sub-Queries for a MultiProvider in Parallel

    http://help.sap.com/saphelp_bw31/helpdata/en/de/bcb73d73a5f972e10000000a114084/content.htm

    Regards

    siddhu

    Message was edited by: sidhartha

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Anil,

      The characteristics/ kfs in my query are from 3 ODS objects where as only vlaues for one ODS are populates rest all are # not assignes. I have also checked the PO numbers are common in ODS objects. One thing more multiprovider is union not join like infoset.

      SO that is why it is starnge. Data from other ODS is not at all shown

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:24 AM

    Hi Baljit,

    Have you selected all the key figures that you want to be displayed.

    Bye

    Dinesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:44 AM

    Hi Baljit,

    Did you modify the query recently. Try regenerating the query in RSRT and check again.

    If that does not work then you would need to debug the query in RSRT and analyse the cause of the problem.

    Bye

    Dinesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2005 at 09:54 AM

    Hi

    Check this :

    MultiProviders with Non-Cumulative Key Figures

    You should not use more than one non-cumulative InfoCube (InfoCube with at least one non-cumulative key figure) because this could lead to incorrect query results.

    Non cumulative key figures is also used in ODS

    Perharps it can help

    Alain

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.