Skip to Content
0

increasing MaxRowsetRecords

Jan 16, 2017 at 04:49 PM

203

avatar image
Former Member

The standard number of records displayed in Crystal defaults to 1,000. We have over 7,000 GL accounts so the report is not working as required. To increase the number of records, I need to increase the limit for MaxRowsetRecords. Can this be done?

10 |10000 characters needed characters left characters exceeded
Former Member

i did the registry fix but still says max 1000 records. Can you check the attachment if its done correctly?1.jpg

1.jpg (128.5 kB)
0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Vitaly Izmaylov
Jan 16, 2017 at 04:54 PM
0

1218588 - How to increase the number of values in a dynamic parameter in Crystal Reports?

Below is the content of the relevant KBA

https://launchpad.support.sap.com/#/notes/1218588


  • How to modify the maximum number of values available in a dynamic parameter in Crystal Reports?

Cause

  • For performance reasons, the maximum number of values that are returned for a List of Values (LOV) in Crystal Reports is set to 1,000.

Resolution

CAUTION The following resolution involves editing the registry. Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall the Microsoft Windows operating system. Use the Registry Editor at your own risk. For information on how to edit the registry key, view the 'Changing Keys and Values' online Help topic in the Registry Editor (Regedit.exe). It is strongly recommended that you make a backup copy of the registry files before you edit the registry.
  • To increase the maximum number of values for a dynamic parameter list of values, set the registry key: MaxRowsetRecords, to a value greater than 1,000:
    1. Open the Microsoft Registry Editor, and navigate to the path corresponding to the version of Crystal Reports used:
      • Crystal Reports 2008:
        - HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\DatabaseOptions\LOV
      • Crystal Reports 2011:
        - HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\DatabaseOptions\LOV
      • Crystal Reports 2013:
        - HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\DatabaseOptions\LOV
      • Crystal Reports 2016:
        - HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\DatabaseOptions\LOV
      • Crystal Reports for Visual Studio 2010:
        - HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions\LOV
      1. NOTES:
        -
        Add the key: LOV, if it is not present.
        - For 64 bit version of Microsoft Windows, the registry path will be slightly different, it will start with:

        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\...

        But the rest of the registry path is the same.
    2. Add the String value: MaxRowsetRecords
    3. Set the value of: MaxRowsetRecords to the maximum number of records in the table where the values are stored. If Crystal Reports application needs to scan 100 000 records to retrieve 20 000 parameter values, set the value to 100 000.


      IMPRTANT NOTES:
      - The higher the number of values set, the longer it will take to see the dynamic parameter prompt screen. In brief, it impacts the performance.
      - The value 0 (Unlimited) will not work with BusinessObjects Enterprise XI or Crystal Reports Server XI, you must specify another value.
    4. Close Crystal Reports Designer and then make the changes to the registry, reopen Crystal Reports, or restart the Crystal Reports services for the BusinessObjects platforms.
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 13, 2017 at 04:00 PM
0

1.jpg

i did the registry fix but still says max 1000 records. Can you check the attachment if its done correctly?


1.jpg (128.5 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 09, 2017 at 11:22 PM
0

I'm having a slightly different issue. The MaxRowsetRecords worked for me, but only in the preview from Crystal Reports application, not when viewed using the aspx Crystal Reports Viewer. Is there a fix for this?

Share
10 |10000 characters needed characters left characters exceeded