Skip to Content
avatar image
Former Member

SAP HANA Studio won't load after software installation failure

Hi,

I've been trying to follow the End to End Development Example for ABAP with HANA at End to End Development Example with SAP NetWeaver 7.4 & SAP HANA

However I have now come to a dead-end as my HANA studio won't load after trying to install the required plug-ins for the SAP Gateway Product Accelerator and the UI Development Toolkit for HTML5 (I already had the ABAP Development tools successfully installed).  When I installed these from https://tools.hana.ondemand.com/juno I got messages about registry errors and when I tried to exit it just got into a loop repeating the error messages.  I eventually had to cancel the application using Task Manager.

Since this error I am unable to load the HANA studio.  When I open it it starts to load - I see messages such as Loading Workbench, and I see very fast message mentioning eclipse (which is so fast I can't read it), but then it just closes down.

I have tried:

Uninstalling & re-installing the studio - the re-installation seems to be successful (clean log, no error messages), but no joy

Uninstalling & re-installing the studio and hana client- no joy

Doing a Windows system restore to about one week prior to this installation - no joy

Doing a system restore with uninstall and re-install- no joy

Prior to this I had a working version of the studio with which I could access my HANA on AWS and was able to browse around the abap development objects and the HANA database procedures etc.  But the End to End Development Example mentioned that these extra plug-ins were required so I tried installing them.

I am on Windows 7 and the HANA studio and client I was using were Win 64 Rev 68.

Also I had been advised NOT to install my HANA studio in C:\Program Files, so it was installed in a folder C:\SAP\hdbstudio

I am stumped at the moment, so would really appreciate some advice on how to move forward.

Thanks

Andy

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Dec 16, 2013 at 03:59 PM

    Hi Andy,

    we are jsut trying to reproduce your problem to investigate it. I'll keep you posted.

    A workaround if you want to continue fast: Reinstall ADT & SAP HANA Studio and install the ODATA Plugin in a seperated Eclipse Installation

    Cheers

    Jens

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thanks so much Sharada!  It was the Workspace issue.  I have now updated my shortcut to the studio including -data "C"\My_workspace" and it works!!  The studio finally launches successfully.

      Now, I need to go back and re-install the ABAP Development tools etc.  Not sure if I am brave enough to try it again!  But at least I now know how to get the studio running again if I hit the same issue.

      Much appreciated.

      Andy




  • avatar image
    Former Member
    Dec 16, 2013 at 09:21 AM

    Hi,

    Did you also try with a lower Studio release like 60 or 64?

    Regards.

    YS

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Yeu Sheng Teo

      Thanks for the suggestion.  I am a little hesitant to try an earlier version though, as I had already had to try a couple of times before I found a version in which I could successfully install the ABAP development tools.  I originally had an earlier version but when I tried to install the ADT I got errors about various Eclipse packages missing. When I used the later version I had no problem installing the ADT.

      Andy 

  • avatar image
    Former Member
    Jan 21, 2014 at 01:05 PM

    I had the same error, but on my SAP HANA Studio for Mac OS. I tried a lot of actions, but you can try these steps:

         1 - Try to open https://tools.hana.ondemand.com/juno or https://tools.hana.ondemanda.com/kepler

              If you have access and it's working you need to download the certificate that's your browser is      using

         2 - Copy the certificate;

         3 - Close your Eclipse (or SAP HANA Studio);

         4 - Find your %JAVA_HOME%/lib/security/cacerts. This path it's responsible to store your credentials

         5 - Import your certificate to your cacerts directory

              sudo keytool -import -noprompt -trustcacerts -alias "avast! trusted CA" -file      "/Library/Java/Home/lib/security/*.hana.ondemand.com.cer" -keystore "/Library/Java/Home//lib/security/cacerts" -storepass "changeit"


    Rgds

    Add comment
    10|10000 characters needed characters exceeded