Skip to Content
0
Former Member
Dec 13, 2013 at 05:03 PM

Corrupt memory issues in addons after upgrade to 9.0

28 Views

Hello everybody:

I have been pulling my hair out over this one, since it is very frustrating.

Simple add-ons developed using DI API, after the customer upgrades to SAP B1 9.0, start giving out "Corrupt memory" errors such as "Attempted to read or write protected memory. This is often an indication that other memory is corrupt.".

That error would show up anytime some type of error is encountered, such as: "exchange rate not updated", "base document is closed", error messages based on validations in SBO_SP_TransactionNotification, etc. The problem is that this "blinds" the user from seeing the real reason for the error and generates a large number of support requests for trivial situations. It also makes it practically impossible to develop on DI API 9.0 because you cannot interpret the errors that occur. ()

This is happening not only with one customer, but with several, so I don't think it's related to the customer's DB. One of the customers is already at 9.0 PL08, which is the latest patch for now, so I don't think it's because we still need to apply another patch.

I'm thinking that many other developers should be hitting this roadblock as we speak, so I wanted to see if I am really not alone in this, and whether anybody has gotten any closer in pinpointing the real problem here...

Looking forward to your comments...

Joerg.