Skip to Content
0
Former Member
Dec 12, 2013 at 03:13 PM

Getting prompted for OK_Code in LSMW and LSMW changes not working

838 Views

I am simply creating a test LSMW to see how it works. I am using a recording.

I have many materials that have already been added to a plant into a main storage location and my goal is to add an additional storage location in this plant to all of these materials.

When I do the recording, it asks me for the transaction, which I am using MMSC. I enter an item number and a plant. On the next screen I add the additional storage location, hit enter, then click on save. At this point I am taken our of the recording. All of this seems fine to me. If I go into MMSC afterwards, the new storage location that I added in the recording is in there as expected an all appears fine.

Then I specify the fields, mappings, etc. This all appears correct to me. I create the input file etc.

When I run the Batch Input Session I am prompted twice for an OK code. It is a simple one line prompt and the OK code value is already in there and it appears as if it simply wants me to click the green check (as if to confirm the OK code). After doing this twice it exits. However, when I go into MMSC, I do not see my new storage location added.

What am I doing wrong? Input file appears correct and in fact from my perspective, it all looks to be set up correctly. Just gettting prompted and it does not add my values. This is the first one of these I have done which is why I am doing this. I want to know how to do it.

All help appreciated.