Skip to Content
0
Former Member
Dec 11, 2013 at 03:10 PM

Crystal Reports for VS2010 - Every other record is being skipped

26 Views

What causes every other record to be skipped with a Crystal Report? I set up my report to point to a custom calss object to provide the field structure, etc. I am setting my datasource at runtime against my report and prior to loading the report I looked at my DataTable I am using to populate the report with. While debugging the application I looked at the query results from the database and the record count shows 2700+ records. However, when my report renders I only get half of that information to display on the report. So, I did some investigation and thought maybe it was a null value issue or something along those lines. When I delved into it deeper and looked at the report output vs. what I am expecting the report is actually skipping every other record. Is this a known issue and if so is there a work around for it? I'm new to Crystal Reports so I am beside myself on this one as it does not make sense to me why records would be skipped.

As a test I also used a LINQ query to extract my data from the DataTable I created into a LIST<T> of the Custom Class Object I set the report up with at design time. I can confirm that even using a LINQ query as the datasource and the DataTable shows me that all expected data from the database is present. Also, I have confirmed that with even using LINQ to supply the data source to my report the report skips every other record.

I have no selection criteria, grouping, etc defined on the report. It's a straight forward retireve the data and dump it into the report. So I am really at a loss here.

Any assistance is appreciated.

Thank you.