Skip to Content
0
Former Member
Dec 11, 2013 at 09:57 AM

Problem with FPN content

107 Views

Hi, we currently have a problem with any new transports we
try and add into the production portal when consuming content from the
federated producer portal. We follow the transport process through

Producer

Create Content

Add to Workset

Create Transport Package

Add Content and Workset to transport package

Transport from CIBWD – CIBWQ – CIBWP All goes through fine
content is visible and works as I would expect

Consumer

Copy content to Dev Producer and past as local content

Create transport package

Add local content to transport package

Transport from JCEPD – JCEPQ this works fine content is
there and working

As soon as we transport to JCEPD, the delta links of the
content breaks

We initially noticed this on some new content that was
created yesterday as screen shot above, this morning I have followed the same
process, but with content that is already in use in the production portal and
is still working fine, but added to a new folder, and transported through in
the new folder and the same thing happens, works fine through D and Q when we
hit prod

I have tried copying the content directly from CIBWP – JCEPP
which I know ya shouldn’t do, but just for testing purposes

and we get this error when trying
to copy any content


All exisiting content, stuff that is already in place is
working fine and the delta links are happy, we have no problem at all with
existing content.

When I run the PCD inspector on the content, and trace the
delta link dependences I get this


All the delta links communicate on the P4 port communication
protocol, and this is all configured correctly, this is the standard p4
configuration for the SAP Portal


The registration is happy and the producer and consumer are
all registered


The connection testing passes fine


We do get an error on the remote delta link testing, as
below


But SSO is working fine and the p4 hostname is there.

Have read a few SDN articles and they all try and point you
in the P4 port config, but I cant see this is wrong, and has not changed since
we last did some transports about 2weeks ago to today, and if the p4
communication was not working all existing content would have broken delta
links

I also tested this by telneting from jcepp to cibwp on the
p4 port and this seems to connect


And back again from cibwp to jcepp


To me this looks to be working ok as well.

We use FQDN in all of our hostname communication, I did read
another article around different IP address and JVA having a module in the
dispatcher then you need to tell it to force to a set IP address but I could
not find that in JVA anywhere.

I am planning on staying late tonight to try and register
and un register the producer to consumer relationship and have a look at that
side of things, but with the content that has not been transported recently
working quite happily I can’t see how the registration will be the problem.

I am at a bit of a loss as to what this could be, if anyone
could offer any help I would be greatly appreciated.

I have attached all screenshots in the jpeg attached to the bottom of the post, thankyou in advance for any help you can offer

Cheers

DC

Attachments

Untitled.jpg (78.4 kB)