Skip to Content
0
Dec 10, 2013 at 06:10 AM

HANA runtime for SAP UI5 on SP6 not working for new UI5 toolkit > 1.14.5

22 Views

Hi All,

I am on HANA SP06, and I have updated by UI5 toolkit to 1.16.5 on my studio.

Now when I run the UI5 application on HANA XS with UI5 controls from libraries like sap.ui.unified(which is available in the new toolkit I downloaded)

the HANA runtime is not able to identify these libraries.

and gives me a 404 not found when I run my Application.

My bootstrap looks like

<script id="sap-ui-bootstrap"

src="/sap/ui5/1/resources/sap-ui-core.js"

data-sap-ui-theme="sap_goldreflection">

data-sap-ui-libs="sap.ui

</script>

Is this correct? should I point my bootstrap to the newly loaded 1.16.5 libraries? If yes, how do I do it?

Please share your thoughts.

Thanks,

Surendra