Skip to Content
author's profile photo Former Member
Former Member

DB02 database history not showing

Hi Friends

recently we upgraded my SAP ECC 6.0.EHP3 system DB from mssql2005 to MSSQl2008r2, after that my sap system is working fine but

when iam checking DB02 for Database Size History , that time iam getting warning message like No

No size history ,check job details

and SAP SQL Statistics is showing yash color symbol

but all the jobs are working fine..

Please give me the reason for this.where i need to changes.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2013 at 12:56 AM

    Hi,

    Is the job SAP_COLLECTOR_FOR_PERFMONITOR running and saposcol is running.

    as per the note you should see the data in there.

    1027512 - MSSQL: DBA cockpit for basis release 7.00 and later

    • Applying SP12 on a SQL Server system will introduce a new method for collecting database and table size histories. This new methode relies on t-sql objects sap_tabstats, sap_tabstats_V_newest, and sap_tabstats_V_oldest. These items aren't in the data dictionary and should be ignored in any discrepancy reports. They are added to an exception table for SP13.

    The structure of table MSQSNAP was changed in SP12 to allow extremely large size values. To avoid a full table conversion of table MSQSNAP the table will be truncated when SP12 is applied. This means that the option in DBACOCKPIT -> Performance -> History -> Performance History will only show the data which is collected after you apply SP12. The older data can still be accessed as described below.

    Also check this.

    Login to MS SQL Server Management Studio --> SQL Server Agent ---> Jobs. Do you see SAP_SID_MSSQL_COLLECTOR.

    Can check the history by Right Click and choose View History.See if any errors are occurring.

    Also you could run the following script:

    use <SID>

    go

    setuser '<sid>' -- the system ID in lowercase

    go

    EXECUTE sap_dbcoll

    go

    Hope that the time zone is set correctly.

    Thanks

    Rishi abrol

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.