Skip to Content
avatar image
Former Member

PI 7.3 Dual Stack : Alerts not working

Hi All,

We are working on PI 7.3 dual stack. And we are using advanced adapter engine concept. For all the interfaces we are creating Integration Configurations.

I have configured alerts in ALRTCATDEF, created the alert rule in RWB. Mail server set up is also working.

When I trigger the alert manually from RSALERTTEST in se38, and process it from RSALERTPROC, it gets delivered to my Inbox. However when the message encounters error in PI at runtime, the alerts doesn’t get triggered.

 

The alert rule is all generic, we have set * in all the fields.

As per the below mails and sap help, basis has done setting in NWA as well,and we have restarted the server. However it didn’t work.

http://help.sap.com/saphelp_nw73ehp1/helpdata/en/b2/58b14b70744d0db55599230d2c5bce/content.htm

http://scn.sap.com/thread/3374746

Please guide me on this issue resolution.

Thanks,

Ruchi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Dec 05, 2013 at 12:02 PM

    Hi Ruchi,

    try like this.

    stop receiver channel and send message. wait for message to go into error state. this you can see in the adapter engine monitor.

    Then check if it triggers alert.

    i remember when i was trying for ICO scenario's alerts, it did not give alert for runtime but cc error i got.not sure if i have made anything wrong.

    do you have anyother classical intefaces which triggers alert for error?

    Regards,

    Muniyappan.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 05, 2013 at 12:47 PM

    Hi Ruchi,

    Try changing the value for component based monitoring from 0 to 1 . Also check if you have ticked suppress multiple alerts checkbox when creating alert rule. Try removing * and create a dummy alert and cross check..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 05, 2013 at 01:10 PM

    Hi Ruchi

    Please make sure that the rule is active in RWB.

    You can check the same in table SXMSALERTRULES using SE16.

    If the rule is not active, then select the active option, save and then click on update table which is present near alert category in RWB.

    You can also check the log using program SXMSALERT_LOGREADER in SE38.

    Also if you have chosen Suppress Multiple Alerts of This Rule , then make sure that you have read and confirm the alert messages in your alert inbox.

    Add comment
    10|10000 characters needed characters exceeded