Skip to Content
0
Former Member
Dec 04, 2013 at 02:55 PM

Auto UD Program RQEVAI30 not running in Background

1131 Views


Hello QM experts,

I am trying to run the Auto UD program RQEVAI30 (Varient created in T-code QA10 for one XXXX Plant) in Background. Program is scheduled in Background to run after every 15 Mins. System is getting the inspection lot nos in this batch job after Insp. Lot getting created.

But after getting Inspection lot nos in the batch job, system is giving the error as mentioned below.

"No batch input data for screen SAPLSPO1 0500"

Same program when I tried to run in foreground (Using QA16 Transaction by selection option "UD in Background) system is giving the same error. Details of the error is as below.

"

No batch input data for screen SAPLSPO1 0500

Message no. 00344

Diagnosis

The transaction sent a screen that was not expected in the batch input session and which therefore could not be supplied with data.

Possible reasons:

1. The batch input session was created incorrectly. The sequence of screens was recordly incorrectly.

2. The transaction behaves differently in background processing in a batch work process than when running in dialog (SY-BATCH is queried and changes the screen sequence).

3. The transaction has undergone user-specific Customizing and therefore certain screens may be skipped or processed differently, according to the current user. If the person who created a batch input session is not the same as the person now processing it, this problem may occur frequently.

System Response

None.

Procedure

For 1: Either re-create the session or process it in expert mode. Correct the batch input program.

For 2. It is very difficult to analyze this problem, particularly in the case that the screen sequence or the display-only options of fields differ according to whether the transaction is being processed in the background or as an online dialog. It could also be that this kind of transaction cannot run with batch input.

For 3: Have the creator of the session process it. If no error occurs now, then this is a program with user-specific Customizing."

There is no issue in varient & data maintained in Varient becuse on DEV & QA server progrm is running successfully whereas in PRD server it is givng above mentioned error.(All data maintained in Varient is same on all 03 servers)

Please help me out to resolve this issue as it is quite urgent issue.

Thanks in Advance. Waiting for your valuable reply.

Thanks

Pravin