Skip to Content

Confused on SAP Netweaver Installtion

Hi,

First of all I would like to begin by saying that I am new to the world of SAP NW I come from traditional understanding of SAP R/3 and ECC versions, BUT, nothing about NW.

So i know that SAP NW is for HCM, SCM and CRM and such.

And ECC 6.0 is for the traditional modules like FICO, PM and such

So my question is this. Currently I have a IDES ECC 6.0 ehp4 on windows2008r2 and it is running fine. Oh, btw it is running on ABAP stack, below image might be more descriptive this is using Oracle DB btw

So i want to install SAP NW 7.4 using Oracle, so was wondering can i install on the same Virtual Machine as my IDES ECC 6.0? or have to be on a spearate machine? Tks

So am I right to say that this NW 7.4 can run on its own with out having a ECC 6.0 system? Cause what I am thinking is that lets say HR module is already present in the ECC version and HCM is part of NW buisness suite, so the data of HR have to be used for HCM (this might be really a silly question but sorry I am more of a HW and then slowly progressed to SAP Basis guy)

I also know that it is possible to have dual-stack, but this has been continued from NW 7.4, except for PI, so what does that mean?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 04, 2013 at 01:49 PM

    1. NW 7.4 SID (System ID) must be different that of IDES

    2. NW74 might be a preview version whereas your ECC is IDES with sample data for practicing.

    3. For NW74 PI supports dual-stack i.e. java and ABAP stack under single SID (System ID)

    regards,

    Nikhil

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      So please correct me on the following this that I assume, If I am wrong.

      So I can't obviously install NW 7.4 on my present IDES system.

      Yes , You can install NW7.4 present same server not inculde in IDEAS. if you have a good hardware than you can gohead and install NW7.4 by creating a new database at present server.

      Make it simple SAP ECC is core component that you can include BI,PI ,EP with ECC during first installation. This way SAP comeup with that and the New dimensional product are called SRM,CRM and SCM ,MI etc... are

      Before it was separated from starting version like 4.6,4.7E and BIW XI..

      Even you can add HCM in ECC6.0 with differnt client using addon.

      Mostly  the good system landscape i install separated which will not affect the business...

      Last point, in real world existing ECC's technical compoenent/stack is upgraded to new version (see versions in Yves post).

      yes, You have to follow for latest patch or upgrade the ECC and other component to use new innovation ad bug fixing.

      Thanks,

      BM

  • Dec 04, 2013 at 03:56 PM

    Hi,

    If you are running ECC you already have a NetWear stack, NW is just the technical basis for SAP applications (just like Fusion in Oracle world).

    Depending en ECC version the NW stack could be :

    • ECC6              NW70
    • ECC6 Ehp4       NW70 Ehp1
    • ECC6 Ehp6       NW73 Ehp1
    • ECC6 Ehp7       NW74

    For wich usage are you willing to install NetWeaver ?

    According to the usage there are version dependencies with the backend (ECC).

    Best regards

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Tom

      You're true MCOD could be a problem if you share a DB between applications that has antagonist usages, like OLAP/OLTP => BW/ECC

      There was a nice trick in note 712777 - MCOD operation of R3 and BW in a database for having some parameters set to different values at session level.

      I do not think that sharing a DB with a JAVA system can be an issue as the Java stack does not make an intensive usage of the DB

      Thanks for the Hana note.

      Kind regards

      Yves

  • May 05, 2015 at 10:48 AM

    Gentlemen,

    sorry for late reply, was away.

    Thank you for your help and clarification.

    If possible, would you please confirm that the required media list for that installation is something like:

    SAP Netweaver 7.4

    51049350_5     SAP Kernel 7.42 Linux on x86_64 64bit

    51048524_6     NW 7.4 SR2 Java 1/2

    51048524_7     NW 7.4 SR2 Java 2/2

    51045590 NW AS ABAP for Suite/NW 7.4 - Enhancement Packages (do I need this one?)

    EHP7 FOR SAP ERP 6.0

    51048902_1     SAP ERP 6.0 EHP7 SR2Installation Export I 1/2

    51048902_2     SAP ERP 6.0 EHP7 SR2Installation Export I 2/2

    51048902_3     SAP ERP 6.0 EHP7 SR2Installation Export II

    51048902_4     SAP ERP 6.0 EHP7 SR2 Language I 1/2

    51048902_5     SAP ERP 6.0 EHP7 SR2 Language I 2/2

    51048902_6     SAP ERP 6.0 EHP7 SR2 Language II 1/2

    51048902_7     SAP ERP 6.0 EHP7 SR2 Language II 2/2

    51048902_8     SAP ERP 6.0 EHP7 SR2 Language III

    51048902_15   BS7i2013 SR2 Java Components - NW 7.4

    51048902_16   SAP ERP 6.0 EHP7 SR2 SAP Components

    This is to run under Oracle Linux 5/6 and ORACLE DB (ASM), eventually, productive might end up in Oracle Exadata and Exalogic.

    Assuming that at the end, with this media, I'll get both the ECC6 EHP7 and the ADS.

    Thank you.

    Joao

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member João Costa

      Hi,

      It is highly recommended to install both as separate SID & database as well for ABAP & JAVA Stack.

      In future if any technical issue comes with any stack, you can easily restart or work independently to each other and solve the issue.

      Thanks

      Ashwani