Skip to Content
author's profile photo Former Member
Former Member

Adobe forms, activated, but says not active.

Hi Friends,

I have copied the standard driver program /1PYXXFO/SAP_PAYSLIP_KSA_PRNT

And Form name is PYXXFO_SAP_PAYSLIP_KSA to ‘Zee’ Program and ‘Zee’ Adobe form.

And also activated both correctly, and in the driver program changed the code and replaced with the new form name ZSAP_PAYSLIP_KSA.

When I execute the driver program it says program does not exists.

If you can open the driver program and see, there are two places which i have replaced the adobe forms.

What is the issue. Names are correctly matched.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Dec 04, 2013 at 12:58 PM

    Hi Obaid ,

    Make sure with your functional consultant that they have configured your form for output.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      The configuration is done as follows.

      Go to T.code HRFORMS and click create

      give the Form name , country grouping and continue.

      It creates by default the following. Here the smart form name is the Adobe form name.

      You have to activate the following below by double clicking each.

      Select the HR FORM tab and you see this.

      ABAP Dictionary Structure /1PYXXFO/ZPAYSLIP_KSA Active

      SAP Smart Form Name ZPYXXFO_ZPAYSLIP_KSA Active

      Print Program /1PYXXFO/ZPAYSLIP_KSA_PRNT Active

  • Posted on Dec 04, 2013 at 12:11 PM

    Hello Obaid,

    Check whether you are able to execute the standard form PYXXFO_SAP_PAYSLIP_KSA directly from SFP first?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pavan,

      /1PYXXFO/SAP_PAYSLIP_KSA_PRNT driver program is working perfectly fine and calling the adobe form. But there is no such form Exists like mentioned in the standard program ' SAP_PAYSLIP_KSA'

      But instead there is form name by PYXXFO_SAP_PAYSLIP_KSA.

      I have replaced the above name with Z.

      Capture.JPG (16.9 kB)
  • Posted on Dec 04, 2013 at 03:39 PM

    Hi Obaid,

    Please Pass the parameter IM_Activate with certain value.As this parameter is empty ots thrpwing you the error.

    Regards,

    Varun

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.