Skip to Content

disable dev_jrfc.trc

Hey guys,

i got a problem on our Netweaver Portal Server. In folder sapmnt\<SID>\<SID>##\j2ee\cluster\server0 there are a lot of dev_jrfc,trc files with 8 mb (on a single day some gigabytes..)  and hdd space run short. Usually it should help to change -Djrfc.trace, -Djco.trace_level, -Djco.jarm to 0 in configtool and restart the cluster. But in my case it doesnt work, it takes no effect. whats wrong?

Into the trc logs are only written some  RFCIO_ERROR_INTERNAL(3) but it doesnt matter because connections are working. So we can disable the trace. Here the instance_ID settings

 

sv-sap-3-1.jpg (30.4 kB)
sv-sap-3-2.jpg (52.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Dec 04, 2013 at 01:51 PM

    Hi Steffen,

    Kindly refer the below link  :

    http://wiki.scn.sap.com/wiki/display/SI/Java+Connectivity

    Let me know if it helps you .

    Regards

    Ram

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 04, 2013 at 10:17 AM

    Hello

    Start Visual Admin and navigate to Server - Services - JCo RFC Provider - Select the JCo RFC under Runtime - Special Settings

    Check the trace level here.

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 04, 2013 at 10:19 AM

    Hi,

    can you please check the below link.

    Tracing JCo Calls - Administration Manual - SAP Library

    thanks

    Rishi abrol

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 04, 2013 at 10:21 AM

    Hello Steffen,

    Can you change these settings in NWA and restart the instance.

    NWA -> Configuration -> Infrastructure -> Java System Properties -> Services tab -> Jco RFC Provider -> set 0 for jrfc.trace & jco.trace_level.

    Regards,

    Mudasir.

    Add comment
    10|10000 characters needed characters exceeded

    • can´t do this steps on NWA. I can only check it with following steps Configuration / System Properties - Instance - server0 and the parameters are shown under java.parameters.

      i checked on Systeminformation > server0 > vm parameters / system properties  all 3 parameters set to "0"