Skip to Content

Filter option in ALV

Hi

When i choose a column in an ALV Grid and click on Filter icon, i am getting a input field that is smaller in lenght than the data in that column. Now how do i increase the lenght of that field. I used the FieldCatalog merge that refers to the Structure where i have all fields of Lenght Char 40. But i can only key in 16Chars in the filter input fields. Pls Help

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • Posted on Oct 17, 2005 at 07:54 AM

    Even if i select 20 chars string also it is accepting. But whenever i give a lenghty selection, only 20 chars appear in the input field of which 16 chars r visible. This is the reason why i am not getting the correct display

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2005 at 07:50 AM

    I mean to say, it truncates the value that i give and takes the first 16 char as filter and tries to fetch rows matching the first 16 chars.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2005 at 07:28 AM

    SomeBody Help Plz!!!!!

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2005 at 08:10 AM

    Thanks everybody. My issue is still not solved. When i select an entry of say 30 chars, it gets truncated in my case in the Input field of the Filter. I guess i should made some mistake somewhere else.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2005 at 08:15 AM

    If i manually key in data to the filter input field, it is not allowing me to key in more than 20 Characters. Should i change any settings ?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2005 at 09:37 AM

    Ok People, I guess in 4.6C it accepts only 20Chars and in 4.7 version it accepts 40 Chars...

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.