Skip to Content
author's profile photo Former Member
Former Member

SAP NetWeaver Gateway 2.0 problem with Solution Manager

Hello SNC members,

Could you please help me?

I installed and configured SAP NetWeaver Gateway 2.0 SP07 to start to use some Solution Manager Mobile Apps, specifically the SAP IT Incident Management. It is an Embedded System scenario, with Solution Manager 7.1 SP10.

Now I’m facing some problems about no data found from Incident Management on the device app that I believe could be related to the Gateway.

I checked the log on both gateway transactions and found this:

/IWFND/APPS_LOG

Message 2 details:

Message 6 details:

Message 7 details:

/IWFND/ERROR_LOG

What could it be? Is possible to be an SAP System Alias problem? In both logs it appears like SD0CLNT500 but on Gateway configurations it is defined LOCAL_SM, according with sap note 1786290 - Solman Setup:System alias could not be created successfully

SPRO > SAP Solution Manager Implementation Guide > SAP Customizing Implementation Guide > SAP NetWeaver > Gateway > OData Channel > Configuration > Connection Settings > SAP NetWeaver Gateway to SAP System > Manage SAP System Aliases

SPRO > SAP Solution Manager Implementation Guide > SAP Csutomizing Implementation Guide > SAP NetWeaver > Gateway > OData Channel Development with IW_BEP > Assign SAP System Aliases to OData Services

Any suggestion is welcome!

Best Regards,

Marcus Campos

Gateway 1.png (26.4 kB)
Gateway 2.png (9.0 kB)
Gateway 3.png (9.9 kB)
Gateway 4.png (10.4 kB)
Gateway 5.png (44.0 kB)
Gateway 6.png (14.3 kB)
Gateway 7.png (22.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Nov 28, 2013 at 08:16 PM

    - For embedded scenario (Gateway + SolMan in same system), 'Local App' needs to be checked in System Alias Configuration.

    - Can you check if you can use the service from the browser? atleast the metadata? If you do not know the URI, go to /IWFND/MAINT_SERVICE, select your service. There should be a button to see the service document. Also in the same Tcode on right botton, you can see the system alias used by this service. Is it the same as LOCAL_SM?

    -Krishna

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Krishna Kishor Kammaje,

      Thanks for your reply.

      I marked the ‘Local App’ option according with your orientation in Systema Alias Configuration.

      Apparently It didn’t change anything on the error message of the mobile app.

      I entered in transaction /IWFND/MAINT_SERVICE and checked the system alias of the service as LOCAL_SM.

      But I don’t get it why in transactions /IWFND/APPS_LOG and /IWFND/ERROR_LOG the system alias appears like SD0CLNT500. Could that affect somehow the correct gateway behavior?

      Best Regards,

      Marcus Campos

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.