Skip to Content
author's profile photo Former Member
Former Member

quick question on Development configuration

Hi,

Created an SC and imported Development configuration and created a DC and performed the steps and whole process was fine..that is i was able to deploy on test system using JDI.

I want to add one more DC to this SC, so i removed my development configuration from NWDS and imported it again and in the inactive workspace, context menu of the compartment, selected "Create new DC" and created one, and assigned an activity to that

I went to activities view and check in and then it popped up for activation. clicked on activate and then now assigned a request id for that. IT stayed there for a long time.

CAME BACK NEXT DAY

Started CBS web GUI and went to "Requests" Page and for that particular request id, in the column "CONFIRMED", it showed "-". so, I selected that request and clicked on "CONFIRM". and went back to NWDS and released the activity and came back to CMS to perform all the transport process, so the file is deployed in Test server Now.

But as i said, why did it take a day ?

a) Am I missing some concept of Development Configuration here. When will the Development Configruation change and how often should a developer remove and import the Development configuration?

b) When I create a SC with a DC and checked in and activated, it was fast. but when i tried to add second DC to the same SC and tried to activate that, as I said it took a day for me. what might be the problem.

is there some time specified that when a build must occur. if that is the case, how was my first SC with a DC worked fast? any thing missing here?

please help me in this regard.

Thank you

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Oct 16, 2005 at 10:53 AM

    Hi Shiva,

    regarding your question a), IMHO it is not neccessary to remove/import your development configuration when you ad a new DC. You need to reimport the dev conf when you add a new SC or use 'restore system state' in the cms due to changes in the CMS. The NWDS shows an information when a new development conf. is available.

    For b) You can switch the autobuild on/off but it seems to be on in your case. Maybe look at the logs in the 'requests' section of the CBS if additional requests where created due to adding the second DC (rebuild of the compartment).

    Best regards,

    Niels

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Shiva,

      Incase you want to have a look at the CBS logs you can also try going through these files:

      /usr/sap/<Instance ID>/JC<Instance Nr>/j2ee/cluster/server0/log/services/tc.CBS.Service/

      In this directory you will find the CBS logs. Just activate and keep going through these logs. Also you can view the same logs in Log Configurator Service in visual admin. This will give you some ides what CBS is trying to do.

      Regards

      Sidharth

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.