Skip to Content

The system is unable to interpret the SSO ticket received on <SERVER IP>

Hi Experts,

Our BO version: BOE 4.0 SP6.

We have recently upgraded our BW system from SAP BI 7.0 to SAP BI 7.4. After that, we are unable to create new reports / run existing reports based on OLAP Connections. The OLAP Connections are configured as SSO. Reports created on top of Universe(unv) are running fine.

For test purpose, we created a new OLAP connection in CMC with SSO and without specifying any cube/bex. Then we tried to create a new webi from rich client with that connection so that we can select the BEx during report creation. We are getting the error:

com.businessobjects.sdk.core.server.CommunicationException$UnexpectedServerException: [[error.openSapBwBrowsingSessionFailed] 0] <Language=en_US;Data Source=<BW SERVER IP>;SapLoginMode=0;Cube Type=Unknown;JCO_ASHOST=<BW SERVER IP>;SaveLanguage=true;JCO_R3NAME=OBP;TargetProvider=SAPNETWEAVER7X;NetworkLayer=SAPBW_BICS;Authentication Mode=2;JCO_CLIENT=300;JCO_LANG=EN;JCO_SYSNR=01;>,<Error: com.sap.conn.jco.JCoException: (103) JCO_ERROR_LOGON_FAILURE: The system is unable to interpret the SSO ticket received on <BW SERVER IP> sysnr 01

Key: JCO_ERROR_LOGON_FAILURE

Group: 103

Type:

Steps we already tried:

  • Delete the SSO certificate from BW server and re-imported the same.
  • Ensured that there is no duplicate certificate in BW server. The system ID is same in CMC and ACL. in ACL we used 000 client while importing the certificate.
  • Restarted the SIA in BO server multiple times.

Any idea what to be done ?

Thanks and Regards,

Arijit

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Nov 28, 2013 at 02:08 PM

    Hello Arjiit,

    when it comes to topics like SSO established on trust a simple upper case / lower case can make a big difference.

    I would suggest you go through the complete configuration - including the SAP BusinessObjects side with the certificates and ensure that items are named and spelled and written (upper case / lower case) always in the same way.

    I also noticed that your server only has a "CN" item there, there should be a complete LDAP naming convention with CN OU O, ... - you can see the details also in the product documentation for the BI platform.

    regards

    Ingo Hilgefort, SAP

    Add a comment
    10|10000 characters needed characters exceeded

    • I have been so foolish. I was trying to use a development user with a connection pointed to production.

      However, the original issue is still not resolved. But as it is a different error, I shall open a separate thread for the same.

      I am closing this thread. Thanks everyone for your assistance.

      Regards,

      Arijit

  • Posted on Nov 28, 2013 at 05:24 AM

    Also, we observed:

    The STRUSTSSO2 transaction screen is different in BI 7.0 and BI 7.4. In 7.4 version, there is no Binary/Base64 option while importing the certificate. Also, after importing the certificate, no checksum is showing.

    Screenshots attached.

    Is the way to import certificate in BI7.4 is different than the same in BI7.0 ?


    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 28, 2013 at 05:28 AM

    Hi Arijit ,

    Could you please ensure the certificate you created during the configuration of STS has been added to the SYSTEM PSE section of the STRUSTSSO2 transaction and There should be only one certificate for the cluster

    Thanks,

    Sneha Bankar

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.