Skip to Content
avatar image
Former Member

Scheduling Webi Report and sending email to someone with error "SMTP 530 - Authentication required"

Hi All

I have BusinessObjects BI Platform 4.0sp2, I enabled destination email for AdaptiveJobServer and I configured our SMTP server (Exchange 2010) to accept connection from BO server for sending email. But when I scheduled the webi report BO give me the error

“Address error. [Error sending address(es) to SMTP server. Return code: [SMTP 530 - Authentication required.]. Reason: [mail@mail.com].]:[CrystalEnterprise.Smtp]”

Following is my SMTP Setting in BusinessObjects BI Platform 4.0sp2

Domain Name: domain.mail.com

Host Name: hostname.domain.mail.com

Port: 25

Authentication: None

User: testperson

Password: xxx

From: testperson@mail.com

To: testperson@mail.com

Subjects: This is a test

When I change Authentication from “None” to “Plain” BO give me the error ” Login error. [SMTP Server does not support [Plain] authentication protocol. Return code: [SMTP 530 - Authentication required.].]:[CrystalEnterprise.Smtp]

When I change Authentication from “None” to “Login” BO give me the error ” Login error. [SMTP Server does not support [Login] authentication protocol. Return code: [SMTP 530 - Authentication required.].]:[CrystalEnterprise.Smtp]

Through searching relation knowledge, I know Exchange server doesn’t support the authentication of “Plain” and “Login”. So I choose “None” as its authentication. Meanwhile the Exchange Server had created a custom receive connector for the BOE server to grant the BOE server with “anonymous account”.

I found http://scn.sap.com/docs/DOC-44785 and verify if BO Server is talking to Email Sever via command prompt. But at step 4 mentioned in the note. I am getting a message stating "530 5.7.1 client was not authenticated". I found http://scn.sap.com/thread/2041964 who got the same error as me. In this topic the proposal was something wrong with exchange server relay rights. But my exchange administrator has granted the anonymous for the BOE server. I am totally no idea.

Anyone especially who is good at BOE and exchange server or anyone who has such experience can help me to solve the problem?

Regards


Betty

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 16, 2013 at 03:11 AM

    My problem was solved. There are two LAN in the BOE server, after my exchange administrator add both two IP of the BOE server in his allow list, the BOE server can send email to someone.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 27, 2013 at 02:40 PM
    Add comment
    10|10000 characters needed characters exceeded