Skip to Content
author's profile photo Former Member
Former Member

Problems with FTP since SP14

Hi,

we have SP14 since yesterday and now I have a problem with the file adapter.

The FTP File Adapter is doubling the directory name. When I type in CZ as directory I got the error ...FTPEx: CWD failed. "/CZ/CZ": directory not found.

in the RWB. If I use . as directory it works (maybe because ././ works?!).

Does anybody know this problem and how I can fix it?!

Thank you

Thomas

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 15, 2005 at 01:32 PM

    Dear Thomas,

    please try using an absolute directory path. The File Adapter issues two CWD commands in succession, which causes problems for relative paths.

    Kind regards,

    Thilo

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Thomas,

      an absolute path starts with the system's path delimiter (usually a slash), as in "/cz". A relative path is relative to the current working directory and does not start with a path delimiter, as in "cz".

      Regards,

      Thilo

  • author's profile photo Former Member
    Former Member
    Posted on Oct 14, 2005 at 06:47 AM

    Hello Thomas,

    can you give some information about your special scenario.

    From which SP did you move to SP14?

    I would recommend to open asap an OSS call. We had a big problem with AFW after installing XI on SP12. The only solution was a fix coming from SAP!

    Now we plan to move directly to SP14. As we use for most of our scenarios FTP, your threat is not encouraging.

    Best regards

    Dirk

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Well I think I will open an OSS on Monday.

      In the scenario a csv file is parsed into a xml an processed to the BIW. But I think this doesn't matter. I think the problem is the FTP part of the File Adapter. In another scenario I get another exception...

      2005-10-14 15:52:00 CEST: Error: Retrieving file 'test.xml' failed unexpectedly: FTPEx: xml_out: The system cannot find the file specified.

      The permission is 777 so that should not be the problem.

      We moved form SP13 to SP14 and now we have that problem.

      This problem occurres in our development and quality system

      Regards

      Thomas

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.