Skip to Content
0
Former Member
Nov 20, 2013 at 03:48 PM

Service Pack 7's assemblies with version 13.0.2000.0

86 Views

I just installed Crystal Reports service pack 7 "CRforVS_13_0_7.exe" (which is recommended to get integrated with visual studio)

After install, I created a new WPF app and realized that my assemblies version are 13.0.2000.0. (the same if browsing from installation directory)

Is this the correct version?

Should I try uninstalling everything and try again?

For example with assembly CrystalDecisions.CrystalReports.Engine.dll I have two differences between service pack 7 version and my old version (service pack 2). AssemblyCopyright and Assembly description

Service Pack 7 assembly info

======================================

[assembly: AssemblyVersion("13.0.2000.0")]

[assembly: CLSCompliant(false)]

[assembly: Debuggable(DebuggableAttribute.DebuggingModes.DisableOptimizations | DebuggableAttribute.DebuggingModes.IgnoreSymbolStoreSequencePoints | DebuggableAttribute.DebuggingModes.EnableEditAndContinue)]

[assembly: AssemblyCompany("SAP BusinessObjects")]

[assembly: AssemblyConfiguration("")]

[assembly: AssemblyCopyright("Copyright © 1995-2012 SAP BusinessObjects")]

[assembly: AssemblyDelaySign(true)]

[assembly: AssemblyDescription("Crystal Reports for .NET Framework")]

[assembly: AssemblyKeyFile("..\\keys\\crystalpublickey.snk")]

[assembly: AssemblyProduct("")]

[assembly: AssemblyTitle("")]

[assembly: AssemblyTrademark("")]

[assembly: NeutralResourcesLanguage("en-US")]

[assembly: SatelliteContractVersion("13.0.2000.0")]

[assembly: CompilationRelaxations(8)]

[assembly: RuntimeCompatibility(WrapNonExceptionThrows = true)]

[assembly: ComVisible(false)]

[assembly: AllowPartiallyTrustedCallers]

[assembly: SecurityPermission(SecurityAction.RequestMinimum, SkipVerification = true)]

[module: UnverifiableCode]

-------------------------------------------------------------

Service Pack 2 assembly info

======================================

[assembly: AssemblyVersion("13.0.2000.0")]

[assembly: CLSCompliant(false)]

[assembly: Debuggable(DebuggableAttribute.DebuggingModes.DisableOptimizations | DebuggableAttribute.DebuggingModes.IgnoreSymbolStoreSequencePoints | DebuggableAttribute.DebuggingModes.EnableEditAndContinue)]

[assembly: AssemblyCompany("SAP BusinessObjects")]

[assembly: AssemblyConfiguration("")]

[assembly: AssemblyCopyright("Copyright © 1995-2010 SAP BusinessObjects")]

[assembly: AssemblyDelaySign(true)]

[assembly: AssemblyDescription("Crystal Reports for .NET Framework 4.0")]

[assembly: AssemblyKeyFile("..\\keys\\crystalpublickey.snk")]

[assembly: AssemblyProduct("")]

[assembly: AssemblyTitle("")]

[assembly: AssemblyTrademark("")]

[assembly: NeutralResourcesLanguage("en-US")]

[assembly: SatelliteContractVersion("13.0.2000.0")]

[assembly: CompilationRelaxations(8)]

[assembly: RuntimeCompatibility(WrapNonExceptionThrows = true)]

[assembly: ComVisible(false)]

[assembly: AllowPartiallyTrustedCallers]

[assembly: SecurityPermission(SecurityAction.RequestMinimum, SkipVerification = true)]

[module: UnverifiableCode]

thanks in advance