Skip to Content
author's profile photo Former Member
Former Member

Getting error 1603 during an installation of CR for VS 2010

We've got a Windows Forms app, written using VS 2010, .NET 4.0, that uses Crystal Reports for VS 2010. I had to make a change to it because our domain has changed. I republished it (ClickOnce deployment). It doesn't want to install at all, but the problem is with Crystal, which is giving the error:

"'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' after install is 'InstallFailed'"

The process exited with code 1603.

I've searched online and it looks as though I'd have to install the app using elevated privileges, which I tried, but that failed as well.

I've tried installing on 64-bit and 32-bit versions of Windows 7, but it fails, same error.

So, how do I get around this problem?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.