Skip to Content
avatar image
Former Member

Decimals of key figures shown in planning books

Hello Community,

I have following request to solve:

I have one planning area. Within this planning area I have several planning books/data views.

Now, I need one planning book/data view in this planning area where all key figures are shown with 2 decimal places.

In all other planning books/data views the key figures should be shown without decimal places - only even numbers.

Can somebody help how to realize this in a meaningful way......?

Please reply - thanks for your help in advance!

Kind regards

Heinz

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Nov 14, 2013 at 03:10 PM

    Hello Community,

    it seems that this is a very special problem - nobody could give an answer until now.

    I created a message for SAP support - perhaps it is a known problem there and SAP notes are available.

    Please reply if somebody has an idea.

    I will inform about the results of contacting SAP.

    Kind regards

    Heinz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      Transaction /sapapo/sdp8b - select your Planning Book and Data View you wish to change and go into Change mode

      Click on Key Figure (s) you want to amend the Decimal Places for

      Right Click -> Selected Rows -> Decimal Places (in the fly out Menus)

      Uncheck "Value from UoM Table" if it is ticked

      Now you should have two butons "Fewer Decimal Places" and "More Decimal Places", you click on these until you have your required number of places (e.g. 2)

      Should work across different Data Views, I have only ever used the same values for all though. Hope it helps.

      Regards

      Ian

  • Nov 14, 2013 at 03:53 PM

    Hi Heinz,

    In my opinion, for a particular key figure which is used in multiple data views you can't differentiate use of decimal numbers based on data view. If you are using decimals for a KF then same will be applicable in all PB or Data views.

    Good that you are checking with SAP for a standard solution. As a work around you can define a default Macro in other data views which should round of the decimal values for display.

    Regards,

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 15, 2013 at 07:39 AM

    Hello,

    You may need to check the setting in /sapapo/sdp8b for your
    planning book/data view by the following steps:

    1)Enter planning book and data view name in transaction /sapapo/sdp8b,
      check radio button 'Data View', and push button 'Change'.
    2)Highlight the key figure, and right click on the grid. Select
      'Selected Rows' in the context menu, then 'Decimal Places' in the
      second level of the context menu.
    3)Remove check box 'Value from UOM table' and set your own setting.
    4)Save the setting and check the planning book again.

    Best Regards,

    Ada

    Add comment
    10|10000 characters needed characters exceeded