Skip to Content
0
Former Member
Nov 13, 2013 at 12:10 PM

"no data to retrieve" issue

385 Views

  1. Hello.

I am facing a weird situation when i run any report either in Infoview or in Webi Rich Client.

From time to time, when i run an Infoview report, or a Webi Rich Client pointing to the Infoview report, the system launches the message "no data to retrieve in query 1", indicating the query couldn't fetch any row of data. But if i edit the query and get into the query panel to refresh it, surprisingly it returns the correct data and, yet more, when after refreshing the query i run the report it executes correctly. So it seems that in order to fetch data the report must to be refreshed in the query panel first... which makes no sense.

This behavior occurs when login for the first time, or when has passed some time since last run. Also occurs if the report has no filters (just the option "refresh on open") or if some filter is applied. The queries have been checked in the SQL Server database (source) and always retrieve data.

I know i have something wrong configured, but i cannot guess what. Could you help me solve this situation? Any clue?

Thank you very much in advance!!!