Skip to Content
0
Former Member
Nov 13, 2013 at 11:55 AM

Multiple settlement assignment in CO order with RA (WIP)

189 Views

Hi guys,

I need help (kind of urgent).

Here is the scenario:

I use plain CO order.

I have 2 types of costs (say direct costs [DC] and management fee [MF]) to which I want to use source structure in the settlement rule.

I also have revenue [REV] which I don't want to settle.

I use result analysis to put costs into WIP.

What I want is that costs which are not covered by revenue are go/remain in WIP till TECO than I want to finally settle the whole stuff regardless whether revenue exceed costs or not.

In the settlement rule I have only 2 assignments: for DC and MF with FULL.

Here is my config:

  1. I created three type 31 cost elements for DC, MF, REV
  2. The cost elements for DC and MF I put in the source structure.
  3. OKG2 and OKG3: I’m not sure about the settings but for the time being something else is the problem (see at the bottom). However, in OKG2 I set the “order
  4. I defined 3 line IDs for the above costs (DC, MF, REV).
  5. In OKG5 I mapped cost elements to line IDs.
  6. In OKG4 I defined the update for RA: costs to category K, revenue to category E, cost elements accordingly assigned
  7. In OKG8 for each type 31 cost element I created the WIP/WIP Settlement account assignment. With WIPR, which I can't say it's correct or not.

I posted some costs in period 1 and do the RA calculation (KKA1) and settled. Costs went to the WIP account in line with the OKG8 settings.

Then I posted some costs and some revenue in period 2. Do the KKA1 and tried to settle and I got this:

No source assignment found for cost element REV (KD560).

Which is obvious since I don’t want to settle the revenues, they can remain on the order.

When I created additional source structure assignment and put REV into it then I had this:

Debit with cost element REV cannot be settled (KD549).

I don’t want to settle this. In OKO7 the 100% validation is unchecked.

What am I missing?

In tried with both settings in OKG2: “Internal and Service orders w/o Revenue” – checked and unchecked.

(once I pass thru this I might be back with further OKG2/3 settings)

Thanks

Hungry Joe