Skip to Content
avatar image
Former Member

Product Allocation Group Dump

Hi Gurus!

I have a scenario that we already have working Allocation and Availability check. Now we need to use RBA for product substitution also.

The substitution is working in Sales Order, but the Allocation occurs only for "father" product.

I checked in foruns and someone said to use RULE_MATNR instead MATNR fieldcatalog in Product Allocation Group.

Ok, i deleted MATNR and inserted RULE_MATNR in allocation group. But on save i got a short dump:

The ABAP/4 Open SQL array insert results in duplicate database records.

What happened?

Error in the ABAP Application Program

The current ABAP program "GP4Q0DNX8QFFRSZ2QPQJBEI17TY" had to be

because it has

come across a statement that unfortunately cannot be executed.

Error analysis

An exception occurred that is explained in detail below.

The exception, which is assigned to class 'CX_SY_OPEN_SQL_DB', was not caught

in

procedure "CHARS_PLUID_LIST_SAVE" "(FORM)", nor was it propagated by a RAISING

clause.

Since the caller of the procedure could not have anticipated that the

exception would occur, the current program is terminated.

The reason for the exception is:

If you use an ABAP/4 Open SQL array insert to insert a record in

the database and that record already exists with the same key,

this results in a termination.

(With an ABAP/4 Open SQL single record insert in the same error

situation, processing does not terminate, but SY-SUBRC is set to 4.)

I tryed to run

/SAPAPO/ATPCQ_RESET

/SAPAPO/ATPCQ_GENER

but the /SAPAPO/ATPCQ_GENER also give me the same dump.

If i try to "roll back" deleting RULE_MATNR and insert MATNR, no dump occurs and the substitution will occurs normally.

Im new to GATP... can you guys please help me?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 07, 2013 at 06:46 PM

    Hi APO,

    Did you performed following two steps after after changing field to Rule_Matnr;

    Try performing these steps and see if it works after this.

    If not............

    I would suggest you create a new set of data with rule_matnr and check, it should work, as i have also experienced the same in past and were able to resolve the same.

    Rgds

    Sourabh

    Add comment
    10|10000 characters needed characters exceeded

    • Hello MT APO,

      When you have RULE_MATNR field as part of your Product Allocation Group(PAG) in APO, during the ATP check it is unable to find any CVCs which qualifies the required combination.

      After you hit ATP check in the Sales Order , Check Product Allocation Results Screen and Click on "Characteristics", it will display you the actual values of each of the characteristics used in PAG.

      This will help you know what is the value it is trying to check for RULE_MATNR field. Based on that verify whether you have that CVC exist in Product Allocation Group.

      As Sourabh suggested, 1. Delete characteristics combinations from product allocation group and 2. Recreating them should help you resolve all such issues.

      Hope this will help.

      Thank you

      Satish Waghmare

  • Nov 12, 2013 at 06:16 PM

    Hello MTO.


    Here in our system we are using the RULE_WERKS/ rule_matrn without problem.


    Try to do the configurations again.(Sourabh tip)


    I have a few problems when i changed configurations(SCM 7).

    Best Regards.

    Marcelo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 13, 2013 at 04:58 PM

    Problem is solved!

    Thanks for all help guys!!!


    Add comment
    10|10000 characters needed characters exceeded